Einzelnen Beitrag anzeigen
  #1 (permalink)  
Alt 18-04-2009, 19:09
h3R0in
 Newbie
Links : Onlinestatus : h3R0in ist offline
Registriert seit: Feb 2009
Beiträge: 7
h3R0in ist zur Zeit noch ein unbeschriebenes Blatt
Standard HTTP Header Problem

Hallo Leute,

Ich versuche grade mit fsockopen() die Seite 3dl.am abzurufen.
Funktionieren tut es so halbwegs, ich kann einen Header hinschicken und bekomme auch
eine Antwort, nur nicht die die ich haben will.
Ich bekomme immer ein "HTTP/1.1 302 Found " anstatt einem "HTTP/1.1 200 OK".

Auch habe ich das ganze mal manuell mitgesnifft (Wireshark). Ergebnis ist folgendes:

Ich schicke dies hier hin
Code:
GET /index.php HTTP/1.1
Host: 3dl.am
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.7) Gecko/2009032813 Iceweasel/3.0.6 (Debian-3.0.6-1)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip,deflate  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://3dl.am/index.php
Und bekomme diese Antwort
Code:
HTTP/1.1 200 OK
Date: Sat, 18 Apr 2009 15:06:37 GMT
Server: Apache  X-Powered-By: PHP/5.2.8-0.dotdeb.1
Set-Cookie: PHPSESSID=17c3c6b57295cee285a9b02dc1b5187c; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html; charset=utf-8
und hintendran halt noch den ganzen Quelltext.

Wie gesagt, wenn ich den oberen Teil genau 1:1 kopiere und als Header hin schicke, bekomme ich aber nicht das gleiche Ergebnis.
Genau genommen bekomme ich das hier zurück:
Code:
HTTP/1.1 302 Found
Date: Sat, 18 Apr 2009 15:59:52 GMT
Server: Apache
X-Powered-By: PHP/5.2.8-0.dotdeb.1
Set-Cookie: PHPSESSID=b11c1376b06e9a463be4a10e48cbce0f; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
location: /
Content-Length: 0
Connection: close
Content-Type: text/html; charset=utf-8
und dahinter kommt kein Quelltext

Ich hoffe ihr habt mein Problem verstanden und könnt mir helfen

MfG
h3R0in
Mit Zitat antworten