php-resource



Zurück   PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr > Entwicklung > Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.)
 

Login

 
eingeloggt bleiben
star Jetzt registrieren   star Passwort vergessen
 

 

 


Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) Probleme, Apache mit PHP oder MySQL zum Laufen zu bringen? Anpassung an .htaccess, httpd.conf oder php.ini funktionieren nicht? In diesem Forum könnt ihr eure Erfahrungen austauschen.

Antwort
 
LinkBack Themen-Optionen Thema bewerten
  #1 (permalink)  
Alt 12-03-2004, 11:14
hydrococcus
 Member
Links : Onlinestatus : hydrococcus ist offline
Registriert seit: Jun 2003
Beiträge: 425
hydrococcus ist zur Zeit noch ein unbeschriebenes Blatt
Question browscap.ini

hab gestern ein bisschen mit get_browser rumgespielt, infolgedessen
ich mir die browscap.ini installierehn mußte. folgendes script hab ich
um die eigenschaften meines benutzten browsers anzuzeigen.
PHP-Code:
function list_array ($array) {
    while (list (
$key$value) = each ($array)) {
        
$str .= "<b>$key:</b> $value<br>\n";
    }
    return 
$str;
}
echo 
"$HTTP_USER_AGENT<hr>\n";
$browser get_browser();
echo 
list_array ((array) $browser); 
ich benutze den IE 6.0. umso verwunderlicher ist die ausgabe
des obigen script's.
Code:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
--------------------------------------------------------------------------------
 browser_name_pattern: Mozilla/4\.0.*
parent: Netscape 4.0
browser: Netscape
version: 4.0
majorver: #4
minorver: #0
frames: 1
tables: 1
cookies: 1
backgroundsounds: 
vbscript: 
javascript: 1
javaapplets: 1
activexcontrols: 
beta:
ausserdem hab ich nach der installation von browscap.ini eine
fehlermeldung vom apache.
Code:
PHP: Error parsing c:\windows \browscap.ini on line 6299
in der zeile steht folgendes
PHP-Code:
;;;;;;;;;;;;;;;;;;;;;;;;;;
;;; Default 
Browser    ;;;
;;;;;;;;;;;;;;;;;;;;;;;;;;
[Default 
Browser Capability Settings]
browser=Default
Version=0.0
majorver
=#0
minorver=#0
frames=False 
tables
=True
cookies
=False 
backgroundsounds
=False
vbscript
=False
javascript
=False
javaapplets
=False
activexcontrols
=False
AK
=False                               ## line 6299
SK=False
AOL
=False
beta
=False
Win16
=False
Crawler
=False
CDF
=False
AuthenticodeUpdate

was ist da nicht in ordnung
Mit Zitat antworten
  #2 (permalink)  
Alt 12-03-2004, 13:52
hydrococcus
 Member
Links : Onlinestatus : hydrococcus ist offline
Registriert seit: Jun 2003
Beiträge: 425
hydrococcus ist zur Zeit noch ein unbeschriebenes Blatt
Standard

EDIT:

bitte helft...


Mit Zitat antworten
  #3 (permalink)  
Alt 22-03-2004, 16:27
thefox
 Newbie
Links : Onlinestatus : thefox ist offline
Registriert seit: Mar 2004
Beiträge: 1
thefox ist zur Zeit noch ein unbeschriebenes Blatt
Standard browscap.ini

also, um dir zu antworten habe ich mich jetzt extra registrieren lassen....
falls du die anwort noch nicht hast, hilft dir dies sicherlich...

es ist wie folgt:
die browscap.ini Datei ist veraltet, dein 'neuer' Browser wird erkannt.
Du musst deine Datei erweitern, oder eine Datei downloaden und
ersetzen.

Eine Datei findest du hier:
http://www.garykeith.com/browsers/downloads.asp

lade das ZIP runter, dort ist eine PHP_browser.ini Datei. Dann kannst
du die lokale Datei (browser.ini) ersetzen, oder dein php.ini File auf
(PHP_browser.ini ) anpassen...

gruss thefox
Mit Zitat antworten
  #4 (permalink)  
Alt 14-10-2006, 18:25
SonicCGN
 Junior Member
Links : Onlinestatus : SonicCGN ist offline
Registriert seit: Mar 2004
Ort: Köln
Beiträge: 56
SonicCGN ist zur Zeit noch ein unbeschriebenes Blatt
SonicCGN eine Nachricht über AIM schicken
Standard

Ich versteh jetzt gar nix mehr.
Habe mir die BROWSCAP.ini runtergezogen .... Nur wo kommt sie hin...

In meiner php.ini steht

Code:
[browscap]
;browscap = extra/browscap.ini
Wo kommt die nun hin bei Suse 9.1

Cu Sonic
__________________
MySQL 5.0.45 mit PHP 5.2.4 auf Suse 10.0.
GD 2.0.28
Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


PHP News

Die RIGID-FLEX-Technologie
Die RIGID-FLEX-TechnologieDie sogenannte "Flexible Elektronik" , oftmals auch als "Flexible Schaltungen" bezeichnet, ist eine zeitgemäße Technologie zum Montieren von elektronischen Schaltungen.

06.12.2018 | Berni

ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlicht
ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlichtDie bekannte Marktplatzsoftware ebiz-trader ist in der Version 7.5.0 veröffentlicht worden.

28.05.2018 | Berni


 

Aktuelle PHP Scripte

EJS TreeGrid ansehen EJS TreeGrid

EJS TreeGrid is DHTML component written in pure JavaScript to display and edit data in table, grid, tree view or grid with tree on HTML page

09.04.2019 coqsoft@ | Kategorie: JAVASCRIPT/ Components
Suchmaschine redaktionell, Branchenportal zum Geld verdienen

Programmbeschreibung Die Bezahl-Suchmaschine ist in Perl und PHP programmiert (eigenes CGI-Verzeichnis notwendig), benötigt PHP aber keine MySQL-Datenbank. Webmaster haben mit dieser Suchmaschine neben der normalen kostenlosen Registrierung von Lin

06.04.2019 skripte@ | Kategorie: PHP/ Suchmaschinen
Oog Photo-Video-Gallery

Mit Oog Photo-Gallery können Sie einfach und stilvoll Bilder (auch Video & Audio) auf Ihrem PHP5-Webserver veröffentlichen und verwalten. Lizenz: GNU GPL v2

06.04.2019 trottbrand@ | Kategorie: PHP/ Bilder
 Alle PHP Scripte anzeigen

Alle Zeitangaben in WEZ +2. Es ist jetzt 02:57 Uhr.