php-resource



Zurück   PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr > Entwicklung > Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.)
 

Login

 
eingeloggt bleiben
star Jetzt registrieren   star Passwort vergessen
 

 

 


Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) Probleme, Apache mit PHP oder MySQL zum Laufen zu bringen? Anpassung an .htaccess, httpd.conf oder php.ini funktionieren nicht? In diesem Forum könnt ihr eure Erfahrungen austauschen.

Antwort
 
LinkBack Themen-Optionen Bewertung: Bewertung: 1 Stimmen, 5,00 durchschnittlich.
  #1 (permalink)  
Alt 01-05-2008, 13:51
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard libpdf

Hi,

ich google schon den ganzen morgenund habe es bisher doch noch nicht geschafft..

ich möchte gerne per php pdf-dokumente verwenden und dafür die pdflib installieren. jetzt weiß ich nur nicht, wie ich das am besten mache..

ich habe einen apache2 auf debian laufen und habe den einfach per "apt-get install" installiert. gibt es für die pdflib auch ein entsprechendes paket? oder muss ich das selbst machen?

was genau brauche ich denn hiervon?
http://www.pdflib.com/download/pdflib-family/pdflib-7/


danke, für eure hilfe!
Mit Zitat antworten
  #2 (permalink)  
Alt 01-05-2008, 14:24
frodenius
 Registrierter Benutzer
Links : Onlinestatus : frodenius ist offline
Registriert seit: Sep 2006
Ort: Germany, Frankfurt/Main
Beiträge: 156
frodenius ist zur Zeit noch ein unbeschriebenes Blatt
Standard

würdest du auch hiermit arbeiten? dann hast du keinen stress mit der installation.
__________________
blllubb
Mit Zitat antworten
  #3 (permalink)  
Alt 01-05-2008, 14:47
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard

würde ich persönlich gerne, aber leider müssen da andere skripte drauf laufen die libpdf brauchen..
Mit Zitat antworten
  #4 (permalink)  
Alt 01-05-2008, 14:51
pekka
 PHP Master
Links : Onlinestatus : pekka ist offline
Registriert seit: Jun 2001
Ort: Köln
Beiträge: 6.608
pekka befindet sich auf einem aufstrebenden Ast
Standard

Ich kenn mich mit PDFLib nicht aus, aber auf der Installationsseite unten gibt es Manuals, dort wird es drinstehen?
Mit Zitat antworten
  #5 (permalink)  
Alt 01-05-2008, 15:49
tontechniker
 PHP Senior
Links : Onlinestatus : tontechniker ist offline
Registriert seit: Jul 2005
Beiträge: 1.972
tontechniker ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Packages für apt-get.
OffTopic:
Mal wieder jemand mit eigenem Server und ohne Ahnung ...
__________________
Die Regeln | rtfm | register_globals | strings | SQL-Injections | []
Mit Zitat antworten
  #6 (permalink)  
Alt 01-05-2008, 17:55
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Zitat:
Packages für apt-get.
Danke, das ist genau das, was ich gesucht habe..

Zitat:
OffTopic:
Mal wieder jemand mit eigenem Server und ohne Ahnung ...
sorry, ich habe ja nach einem pack. gesucht, aber ich kannte die seite halt nicht.. wir haben doch alle unsere fachbereiche, oder?

leider funktioniert es noch nicht.. ich hab nur eine libpdflib804.so.2.2005 gefunden und die bringt es anscheinend nicht. ich habe die als extension in der php.ini angegeben, aber es hat sich nichts getan..
Mit Zitat antworten
  #7 (permalink)  
Alt 01-05-2008, 18:02
unset
  Moderator
Links : Onlinestatus : unset ist offline
Registriert seit: Jan 2007
Ort: Düsseldorf
Beiträge: 3.782
unset befindet sich auf einem aufstrebenden Ast
Standard

Mal was wegen Paketen: apt-cache search <term> hilft.

Edit: Für PHP-Extensions auch mal mit pecl suchen. pecl seearch <term> - da würdest du auch fündig werden.

Geändert von unset (01-05-2008 um 18:10 Uhr)
Mit Zitat antworten
  #8 (permalink)  
Alt 01-05-2008, 18:43
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Zitat:
Original geschrieben von unset
Mal was wegen Paketen: apt-cache search <term> hilft.

Edit: Für PHP-Extensions auch mal mit pecl suchen. pecl seearch <term> - da würdest du auch fündig werden.
danke für den tipp! damit bin ich auch auf was gestoßen..

Zitat:
server:~# pecl install pdflib
downloading pdflib-2.1.5.tgz ...
Starting to download pdflib-2.1.5.tgz (55,579 bytes)
.............done: 55,579 bytes
10 source files, building
running: phpize
Configuring for:
PHP Api Version: 20020918
Zend Module Api No: 20020429
Zend Extension Api No: 20050606
path to pdflib installation? :
was muss ich dort als pfad eintragen?
Mit Zitat antworten
  #9 (permalink)  
Alt 01-05-2008, 19:37
tontechniker
 PHP Senior
Links : Onlinestatus : tontechniker ist offline
Registriert seit: Jul 2005
Beiträge: 1.972
tontechniker ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Zitat:
was muss ich dort als pfad eintragen?
locate pdflib / whereis pdflib bzw. mal in /usr/bin / /usr/local/bin oder so gucken.
__________________
Die Regeln | rtfm | register_globals | strings | SQL-Injections | []
Mit Zitat antworten
  #10 (permalink)  
Alt 01-05-2008, 19:56
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard

ah, wieder was gelernt. whereis kannte ich schon, aber das hat nix ausgegeben.. locate hat mir aber auch nicht wirklich was neues gesagt:

Zitat:
/usr/lib/libpdflib804.so.2
/usr/lib/libpdflib804.so.2.2005
/usr/share/doc/libpdflib804-2
/usr/share/doc/libpdflib804-2/changelog.Debian.gz
/usr/share/doc/libpdflib804-2/copyright
/var/cache/apt/archives/libpdflib804-2_2005.dfsg-2_i386.deb
/var/lib/dpkg/info/libpdflib804-2.list
/var/lib/dpkg/info/libpdflib804-2.md5sums
/var/lib/dpkg/info/libpdflib804-2.postinst
/var/lib/dpkg/info/libpdflib804-2.postrm
/var/lib/dpkg/info/libpdflib804-2.shlibs
und die zwei lib-dateien kann er ja eigentlich nicht meinen?

das gibt auf jeden fall einen error:

Zitat:
path to pdflib installation? : /usr/lib/
building in /var/tmp/pear-build-root/pdflib-2.1.5
running: /tmp/pear/cache/pdflib-2.1.5/configure --with-pdflib=/usr/lib/
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php4 -I/usr/include/php4/main -I/usr/include/php4/TSRM -I/usr/include/php4/Zend -D_LARGEFILE_SOURCE -D_FILE_OFFSET_B ITS=64
checking for PHP extension directory... /usr/lib/php4/20050606+lfs
checking for re2c... exit 0;
checking for gawk... no
checking for mawk... mawk
checking for PDFlib support... yes, shared
configure: error: pdflib.h not found! Check the path passed to --with-pdflib=<PATH>. PATH should be the install prefix directory.
ERROR: `/tmp/pear/cache/pdflib-2.1.5/configure --with-pdflib=/usr/lib/' failed
Mit Zitat antworten
  #11 (permalink)  
Alt 01-05-2008, 19:56
pekka
 PHP Master
Links : Onlinestatus : pekka ist offline
Registriert seit: Jun 2001
Ort: Köln
Beiträge: 6.608
pekka befindet sich auf einem aufstrebenden Ast
Standard

Dann installier die pdflib halt ordentlich.
Mit Zitat antworten
  #12 (permalink)  
Alt 01-05-2008, 20:19
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Zitat:
Original geschrieben von pekka
Dann installier die pdflib halt ordentlich.
hm, war gar nicht so schlimm

aber funktionieren tut es noch nicht.. er ist zwar richtig durchgelaufen und hat mir auch gesagt ich soll das jetzt in der php.ini eintragen, aber die pdf.so hat er in den ordner /usr/lib/php4 installiert.

ich habe aber php5 am laufen und meine extensions sind im ordner /usr/lib/php5. ich habs dann einfach mal mit nem link versucht, aber ich denke, das kann man so nicht zum laufen bringen..

Zitat:
PHP Warning: PHP Startup: U\x89\xe5S\xe8\xac,\xff\xff\x81\xc3O\x15': Unable to initialize module\nModule compiled with module API=20020429, debug=0, thread-safety=0\nPHP compiled with module API=20060613, debug=0, thread-safety=0\nThese options need to match\n in Unknown on line 0
was mach ich nun?
Mit Zitat antworten
  #13 (permalink)  
Alt 02-05-2008, 20:28
comtim
 Newbie
Links : Onlinestatus : comtim ist offline
Registriert seit: Dec 2005
Beiträge: 36
comtim ist zur Zeit noch ein unbeschriebenes Blatt
Standard

ich hab es jetzt mit php4 gemacht - erstaunlich wie einfach das geht obwohl ich es mit php5 gar nicht hinbekommen habe...

danke an alle!
Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


PHP News

ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlicht
ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlichtDie bekannte Marktplatzsoftware ebiz-trader ist in der Version 7.5.0 veröffentlicht worden.

28.05.2018 | Berni

Wissensbestand in Unternehmen
Wissensbestand in UnternehmenLebenslanges Lernen und Weiterbilden sichert Wissensbestand in Unternehmen

25.05.2018 | Berni


 

Aktuelle PHP Scripte

PHP Server Monitor

PHP Server Monitor ist ein Skript, das prüft, ob Ihre Websites und Server betriebsbereit sind.

11.09.2018 Berni | Kategorie: PHP/ Security
PHP WEB STATISTIK ansehen PHP WEB STATISTIK

Die PHP Web Statistik bietet Ihnen ein einfach zu konfigurierendes Script zur Aufzeichnung und grafischen und textuellen Auswertung der Besuchern Ihrer Webseite. Folgende zeitlichen Module sind verfügbar: Jahr, Monat, Tag, Wochentag, Stunde Folgende son

28.08.2018 phpwebstat | Kategorie: PHP/ Counter
Affilinator - Affilinet XML Produktlisten Skript

Die Affilinator Affilinet XML Edition ist ein vollautomatisches Skript zum einlesen und darstellen der Affili.net (Partnerprogramm Netzwerk) Produktlisten und Produktdaten. Im Grunde gibt der Webmaster seine Affilinet PartnerID ein und hat dann unmittelb

27.08.2018 freefrank@ | Kategorie: PHP/ Partnerprogramme
 Alle PHP Scripte anzeigen

Alle Zeitangaben in WEZ +2. Es ist jetzt 02:11 Uhr.