php-resource



Zurück   PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr > Betriebssysteme, Hardware & Netzwerk > Linux und Unix
 

Login

 
eingeloggt bleiben
star Jetzt registrieren   star Passwort vergessen
 

 

 


Linux und Unix Forum zum Austausch von Erfahrungen, Problemen, Tips und Tricks.

Antwort
 
LinkBack Themen-Optionen Thema bewerten
  #1 (permalink)  
Alt 18-01-2007, 21:59
asp2php
 Banned
Links : Onlinestatus : asp2php ist offline
Registriert seit: Feb 2004
Beiträge: 11.745
asp2php ist zur Zeit noch ein unbeschriebenes Blatt
Standard [Debian] upgrade auf höhere Version ...

Ja, ich schon wieder

wie überredet man Debian Sarge 3.1 einige Libraries auf eine höhere Version zu gehen. Bei der Installation eines deb-Paket sagt mir das Programm:

Depends: libatk1.0-0 (>= 1.9.0) but 1.8.0-4 is installed
Depends: libgcc1 (>= 1:4.0.0-9) but 1:3.4.3-13sarge1 is installed
Depends: base-files (>= 3.1.6) but 3.1.2 is installed
Depends: binutils (>= 2.16.1-2) but 2.15-6 is installed
Depends: libattr1 (>= 2.4.21-1.0.1) but 2.4.16-1 is installed
Depends: libncurses5 (>= 5.4-9) but 5.4-4 is installed

mit apt-get install ist leider nicht drin, muss man jetzt manuell die Libraries downloaden und per dpkg einzeln installieren? Dabei umgeht man praktisch die nicht freigegebene Grenze von Debian-Pakete, stimmt? Wie sieht denn dann aus, wenn man das nächste Mal mit apt-get update und apt-get upgrade das System aktualisiert? Hat jemand Erfahrung in der Richtung?

Danke im voraus.
Mit Zitat antworten
  #2 (permalink)  
Alt 18-01-2007, 23:30
TBT
  Moderator
Links : Onlinestatus : TBT ist offline
Registriert seit: Sep 2002
Ort: Berlin
Beiträge: 2.787
TBT befindet sich auf einem aufstrebenden Ast
TBT eine Nachricht über ICQ schicken TBT eine Nachricht über AIM schicken TBT eine Nachricht über Yahoo! schicken
Standard

die /etc/apt/sources.list auf die etch Sourcen umstellen also so z.B.
Code:
deb ftp://ftp2.de.debian.org/debian etch main contrib non-free
deb-src ftp://ftp2.de.debian.org/debian etch main contrib non-free
danach ein "apt-get update" und "apt-get dist-upgrade"

ABER VORSICHT damit, er muss beim upgrade von sarge auf etch ein
lebenswichtiges Paket deinstallieren, welches du danach sofort wieder in
der neuen Version installieren musst. Da kommt so eine Sicherheitsabfrage,
die nicht einfach mit "J" beantwortet wird, sondern explizit mit:

"Ja, tu was ich sage!" bzw. auf englisch

Beim upgrade darfst du außerdem viele, viele Fragen beantworten
__________________
TBT

Die zwei wichtigsten Regeln für eine berufliche Karriere:
1. Verrate niemals alles was du weißt!


PHP 2 AllPatrizier II Browsergame
Mit Zitat antworten
  #3 (permalink)  
Alt 19-01-2007, 20:41
asp2php
 Banned
Links : Onlinestatus : asp2php ist offline
Registriert seit: Feb 2004
Beiträge: 11.745
asp2php ist zur Zeit noch ein unbeschriebenes Blatt
Standard

ähm... damit mache ich aber aus einem Sarge ein Etch RC1, stimmt? Hm... das muss ich mir aber wirklich überlegen, denn ich habe keine Lust Sarge nochmals aufzusetzen, da ich z.Z. keinen Platz mehr frei habe, um vorher das System zu sichern. Gibt es wirklich keinen anderen Weg nur die 6 Lib da zu aktualisieren?
Mit Zitat antworten
  #4 (permalink)  
Alt 19-01-2007, 21:20
Shurakai
 Master
Links : Onlinestatus : Shurakai ist offline
Registriert seit: May 2004
Ort: Bergisch Gladbach
Beiträge: 3.084
Shurakai ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Hast du es mal ausprobiert?

apt-get hat nen parameter, der dir nur anzeigt was er alles installieren würde und upgraden würde. Habs grad aber vergessen.

... Musst du wohl oder übel mal die man-page fragen


Damit könntest du ja nachschauen, ob er dir direkt nen etch verpasst. Wenn du apt-get upgrade machst, wird er dir das System aktualisieren. Und vor nem Backup würd ich da sowieso die Finger von lassen
Mit Zitat antworten
  #5 (permalink)  
Alt 20-01-2007, 10:20
Benutzerbild von Meillo Meillo
 Registrierter Benutzer
Links : Onlinestatus : Meillo ist offline
Registriert seit: Mar 2004
Ort: Balmora
Beiträge: 1.869
Meillo ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Zitat:
Original geschrieben von asp2php
Gibt es wirklich keinen anderen Weg nur die 6 Lib da zu aktualisieren?
Stichwort "APT pinning"
Damit lassen sich auch bestimmte Pakete aus anderen Releases installieren. Allerdings wird überall von Versionsmischmasch gewarnt ... man sollte also schon wissen was man tut.

Weshalb brauchst du die überhaupt?
Kannst du das Paket nicht manuell kompilieren, dann reichen deine Libs wahrscheinlich aus.
Oder falls es ein Paket für etch ist, dann findest du es evtl. auch über backports.org für sarge
__________________
Ein großes DANKE an alle, die sich auf selbstlose Weise im Forum einbringen.

btw: REAL PROGRAMMERs aren't afraid to use GOTOs!

Etwas ernster, aber auch nicht weiter tragisch, sieht die Situation bei Software-Patenten aus. Software-Patente sind eine amerikanische Erfindung und stehen auf dem selben Blatt wie genveränderte Babynahrung, die im Supermarkt nicht mehr als solche gekennzeichnet werden soll, um die Hersteller nicht gegenüber denen natürlicher Produkte zu diskriminieren ...
(from here)
Mit Zitat antworten
  #6 (permalink)  
Alt 20-01-2007, 10:53
asp2php
 Banned
Links : Onlinestatus : asp2php ist offline
Registriert seit: Feb 2004
Beiträge: 11.745
asp2php ist zur Zeit noch ein unbeschriebenes Blatt
Standard

ich war zu faul, den source code manuell anzupassen und zu ändern, aber so wie es z.Z. aussieht muss ich doch dadurch. Vielen Dank an alle für die Tipps
Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


PHP News

Die RIGID-FLEX-Technologie
Die RIGID-FLEX-TechnologieDie sogenannte "Flexible Elektronik" , oftmals auch als "Flexible Schaltungen" bezeichnet, ist eine zeitgemäße Technologie zum Montieren von elektronischen Schaltungen.

06.12.2018 | Berni

ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlicht
ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlichtDie bekannte Marktplatzsoftware ebiz-trader ist in der Version 7.5.0 veröffentlicht worden.

28.05.2018 | Berni


 

Aktuelle PHP Scripte

Adsman Pro - Werbe-Manager V.1.1.0

Mit ADSMAN PRO haben Sie die Marketinglösung für eine effektive und effiziente Werbeschaltung mit messbaren Ergebnissen. Unterstützt werden Bannerformate in beliebigem Format, Textanzeigen und Page-Peels mit umfangreichen Text und Flash-Effekte.

30.07.2019 rhs | Kategorie: PHP/ Bannerverwaltung
HeidiSQL - kostenloses MySQL front-end Editor für Windows ansehen HeidiSQL - kostenloses MySQL front-end Editor für Windows

HeidiSQL - ist ein Windows-Editor für die bekannt open Source Datenbank mySQL

30.07.2019 Berni | Kategorie: MYSQL/ Management
Top-Side.de Php Guest Book

Gästebuch mit Smilies, Ip Sperre und Spammschutz. Anzeige von Datum, Name, E-Mail, Homepage und Icq. Html ist deaktiviert.

26.07.2019 webmaster10 | Kategorie: PHP/ Gaestebuch
 Alle PHP Scripte anzeigen

Alle Zeitangaben in WEZ +2. Es ist jetzt 11:57 Uhr.