php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
PHP als fcgi kompilieren


 
sagg
21-11-2007, 16:12 
 
Tag zusammen,

ich versuche gerade PHP 5.2.5 als fcgi zu kompilieren, jedoch bringt mir "php -v" nach der Installation jedes mal, dass es als "cli" läuft.

Kann mir bitte jemand sagen was ich falsch mache?

Hier die an configure übergebenen Optionen:
./configure
--prefix=/usr
--enable-fastcgi
--with-config-file-path=/etc
--with-config-file-scan-dir=/etc/php.d
--enable-force-cgi-redirect
--disable-debug
--disable-rpath
--enable-inline-optimization
--with-bz2
--with-curl
--with-freetype-dir=/usr
--with-png-dir=/usr
--with-gd
--enable-gd-native-ttf
--without-gdbm
--with-gettext
--with-jpeg-dir=/usr
--with-openssl
--with-regex=system
--with-xmlrpc=shared
--with-zlib
--with-layout=GNU
--enable-bcmath
--enable-exif
--enable-ftp
--enable-sockets
--enable-wddx
--with-pear=/opt/pear
--with-mysql
--with-mysqli=/usr/bin/mysql_config
--enable-bcmath
--enable-calendar
--enable-mbstring=shared
--enable-mbregex
--with-libxml-dir=/usr/lib

Muss ich da noch Optionen wie "--disable-cli" oder "--without-cli" übergeben?
Ich könnte es zwar einfach mal ausprobieren, jedoch hat mein Lappi doch schon ein paar Jährchen auf dem Buckel und ich möchte heute auch noch andere Dinge tun. ;)

Vielen Dank schonmal im Vorraus.

 
onemorenerd
21-11-2007, 17:44 
 
<?php phpinfo(); ?>als Datei ins DocRoot speichern und über den Webserver aufrufen!

 
tontechniker
21-11-2007, 18:32 
 
Kann mir bitte jemand sagen was ich falsch mache? Nichts. :goth:

 
sagg
21-11-2007, 22:43 
 
Ach herje, wie dämlich. ;)

Ich hatte PHP erst per Paketmanager installier, einfach um mal zu schauen wie gut das klappt.
Danach war es als cli installiert, ich also die Pakete per Paketmanager wieder entfernt, PHP selbst kompiliert und mich Grün und Blau gewundert, warum es auch jetzt "wieder" als cli läuft...
Im Nachhinein hätte ich gleich darauf kommen müssen, es war schlicht und ergreifend noch immer die Version des Paketmanagers....peinlich. :cool:


Alle Zeitangaben in WEZ +2. Es ist jetzt 13:32 Uhr.