php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
Probleme mit mozilla


 
ekiem
19-02-2008, 21:48 
 
Hallo habe endlich eine Hp mit dreamweaver fertiggestellt (www.tc-sonderbuch.de) Der explorer bringt alles wie gewollt. Der mozilla beginnt die Seite mit i>>und umgedrehtes Fragezeigen. Sowohl in der Fotoshow (adope photoshop cs) wie auch bei der seite club_partnerbörse. Wenn ich bei Ansicht/Zeichenkodierung auf UTF-8 stelle, wird alles korrekt angezeigt. Vielleicht kann mir jemand helfen, was ich verändern muss.
Danke

 
Abraxax
19-02-2008, 21:51 
 
speichere deine datei im utf-8 zeichensatz

und/oder

copy&paste des dateiinhaltes in eine neue datei und speichere diese neu (auch unter gleichem namen möglich)

 
PHP-Desaster
19-02-2008, 21:58 
 
Würde auf eine BOM tippen. Ließ mal hier in meinem Blog! (http://blog.chilicat.de/development/webdevelopment/php/utf-8-bom-entfernen)

 
ekiem
19-02-2008, 22:19 
 
Danke für eure Antwort. Das mit dem BOM kapiere ich nicht, tut mir leid. Und den UTF-8 Zeichensatz habe ich doch angegeben. Was kann ich denn noch mehr tun?

Gruß

 
Kropff
19-02-2008, 22:28 
 
Das mit dem BOM kapiere ich nicht
wikipedia (http://de.wikipedia.org/wiki/Byte_Order_Mark)

1. nicht mehr mit dreamweaver arbeiten :)
2. besorg dir notepad++ (http://notepad-plus.sourceforge.net/de/site.htm), da kannst du unter "format" die option "codiere als utf-8 ohne bom" einstellen
3. ausprobieren
4. alle fehler (http://validator.w3.org/check?uri=http%3A%2F%2Fwww.tc-sonderbuch.de%2F&charset=%28detect+automatically%29&doctype=Inline&group=0) beseitigen

gruß
peter

 
ekiem
19-02-2008, 23:07 
 
Danke Kopff,

Du hast mich auf den richtigten Weg gebracht. Es liegt aber nicht am Dreamweaver. Es war mein Fehler. Ich habe die Seiten erst mit dem Editor gemacht. Als ich später einen Dreamweaver-Kurs gemacht habe, wollte ich den natürlich einsetzen und habe einzelne Seite per Hand einfach hineinkopiert ohne den Head zu berücksichtigen. Somit kamen die Fehler zustande, also Dreamweaver kann dafür nix.

Ich werde deinen Tipp befolgen.

Gruß und Danke

 
ekiem
20-02-2008, 21:25 
 
Hallo Kropff, hat alles wirklich super geklappt ohne Probleme. Habe den Editor installiert. Format gemacht und alles wird so wie gedacht dargestellt. Sehr einfach. Die HTML Seiten laufen jetzt gut. Es ist wirklich klasse, wie ihr anderen helft. Wenn es im Leben immer so einfach wäre. Vielleicht kann ich auch mal jemanden (in vielen Jahren) helfen.

Danke

Also die HTML-Seiten sind jetzt ok. Bei meiner Fotoshow erstellt mit Adope CS 3 erscheint trotzdem der gleiche Fehler (nur im Mozilla). Ist nicht so tragisch für mich, aber vielleicht hat jemand eine Lösung oder eine andere Möglichkeit.

Danke

 
Kropff
21-02-2008, 09:20 
 
aber vielleicht hat jemand eine Lösung oder eine andere Möglichkeit
ganz ehrlich? vergiss dieses klickibunti-programme mit all ihren ach so tollen webfunktionen. besorg dir einen vernünftigen editor (hast du ja schon), lerne es richtig und mach es dann selber per hand und sauber.

gruß
peter

 
st@tic
12-03-2008, 10:39 
 
Original geschrieben von Kropff
ganz ehrlich? vergiss dieses klickibunti-programme mit all ihren ach so tollen webfunktionen. besorg dir einen vernünftigen editor (hast du ja schon), lerne es richtig und mach es dann selber per hand und sauber.

gruß
peter

so schlimm ist der dreamweaver nun auch wieder nicht.
wenn man alles weiß und versteht, kann es wirklich eine erleichterung sein. als anfänger sollte man mitm notepad.exe anfangen :) dann lernt man es wenigstens richtig

 
jahlives
12-03-2008, 11:03 
 
so schlimm ist der dreamweaver nun auch wieder nicht.


Ein Ketzer, ein Abweichler! Auf den Scheiterhaufen mit ihm ;)

 
unset
12-03-2008, 11:09 
 
Grundsatzdikussionen? *popcornhol*

 
jahlives
12-03-2008, 11:21 
 
*popcornhol*


*fackelundholzhol*

Gruss

tobi

 
st@tic
12-03-2008, 14:20 
 
Original geschrieben von unset
Grundsatzdikussionen? *popcornhol*

ne lieber net, sonst sind wir am st. nimmerleinstag noch net fertig.
im grunde ist es ja wurscht hauptsache das ergebnis ist sauber und ordentlich.

 
RanzigeMilch
13-03-2008, 14:49 
 
Original geschrieben von Kropff
wikipedia (http://de.wikipedia.org/wiki/Byte_Order_Mark)

1. nicht mehr mit dreamweaver arbeiten :)
2. besorg dir notepad++ (http://notepad-plus.sourceforge.net/de/site.htm), da kannst du unter "format" die option "codiere als utf-8 ohne bom" einstellen
3. ausprobieren
4. alle fehler (http://validator.w3.org/check?uri=http%3A%2F%2Fwww.tc-sonderbuch.de%2F&charset=%28detect+automatically%29&doctype=Inline&group=0) beseitigen

gruß
peter

schonmal beim dreamweaver auf "modifizieren"->"seiteneigenschaften"->"Titel/Kodierung" gewesen??
da kann man wunderbar die kodierung der datei mit oder ohne bom anwenden...
also bevor man mir den dw schlecht macht bitte mit schlüssigen argumenten:p

 
Kropff
13-03-2008, 15:20 
 
also bevor man mir den dw schlecht macht bitte mit schlüssigen argumenten
ich hab mit dem ding nie was gemacht. daher kenne ich das teil auch nicht, sondern nur die leute, die damit arbeiten :)

außerdem zeigt notepad den bom automatisch an, da muss man nicht erst irgendwo rumklicken.

gruß
peter

 
lennart
13-03-2008, 15:48 
 
Original geschrieben von Kropff
[...]. daher kenne ich das teil auch nicht, sondern nur die leute, die damit arbeiten :)

hehe und das reicht bei denen manchmal schon :D

 
RanzigeMilch
13-03-2008, 17:27 
 
wenn man im dreamweaver standartmäßig dateien in utf-8 erstellt ist die bom option auch automatisch in den speicheroptionen drin
aber is ja egal jedem das seine wollte ja nur dass er wenn er dw gewöhnt ist net deswegen umsteigen muss...

-archiv-

Alle Zeitangaben in WEZ +2. Es ist jetzt 18:33 Uhr.