php-resource.de

Sicherheitslücken in PHP

Berni | Neu | Beitrag gelesen 2447 gelesen |

 


PHP-Entwickler Stefan Esser hat bei den Arbeiten an seinem "Hardening-Patch" für PHP einige Sicherheitslücken in der freien Scriptsprache entdeckt. Darunter auch ein Problem beim Upload von Dateien, das Esser als kritisch einstuft. Betroffen von den S

PHP-Entwickler Stefan Esser hat bei den Arbeiten an seinem "Hardening-Patch" für PHP einige Sicherheitslücken in der freien Scriptsprache entdeckt. Darunter auch ein Problem beim Upload von Dateien, das Esser als kritisch einstuft.

Betroffen von den Sicherheitslücken sind alle PHP-Versionen einschließlich 4.4.0 und 5.0.5. Benutzern von PHP4 wird empfohlen, umgehend auf die neue Version 4.4.1 zu aktualisieren. Für PHP5 ist offenbar noch keine fehlerbereinigte Fassung verfügbar.

quelle :
golem.de/0511/41341.html
hardened-php.net/index.76.html

Kommentare zum Artikel
Artikel kommentieren
 
Verwandte Beiträge
star PHP 5.1, vierter und letzter Release Candidate erschienen.
star MySQL 5.0 ist für den produktiven Einsatz freigegeben
star Release Candidate 3 von PHP 5.1 erschienen
star Apache stopft Sicherheitslücken
star MySQL 5.0 vor der Fertigstellung

 
Links zum Artikel
Über den Autor
Berni

Berni

Status
Premium Mitglied

Beruf
Selbstständig

Mitglied seit:
22.01.2001

letzte Aktivität
23.05.2022