Warnung: file_put_contents(/home/www/web1/html/php_dev/test.txt) [function.file-put-contents]: failed to open stream: Permission denied in /home/www/web1/html/php_dev/sys/lib.activity.php (Zeile 58)
MySQL Dienst startet nicht, Fehler 1067 [Archiv] - PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr

- Ad -
php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
MySQL Dienst startet nicht, Fehler 1067


 
talker
19-02-2003, 15:06 
 
Hallo,


ich habe Schwirigkeiten mit MySQL. Dazu muss ich sagen, dass ich absoluter Einsteiger bin, das Problem also auch an einer Banalität liegen kann.
Letztes Semester hatten wir an der Uni ein Projekt zu bearbeiten, in dem es um eine Benutzerverwaltug bsp. einer Bücherei ging. Wir sollten realisieren, dass sich zukünftige Nutzer via Internet anmelden können und auf der Gegenseite die MySQL Datenbank mit den neuen Nutzerinformationen komfortabel bearbeitet werden kann.
Verwendete Software hierfür sollte sein:
- Apache Tomcat
- Java mit ODBC Treibern
- MySQL
Damals hatte ich diese Software ebenfalls bei mir zu Hause installiert und es lief alles einwandfrei.

Nun komme ich zu meinem eigentlichen Problem:

Als ich nun gestern beschlossen habe, meine Musiksammlung ebenfalls mittels einer MySQL-Datenbank zu verwalten, musste ich feststellen, dass der MySQL Dienst nicht mehr startet.
Wenn ich also aus der Eingabeaufforderung \mysql\bin\ "mysql" eingebe, erhalte ich die Fehlermeldung:
ERROR 2003: Can't connect to MySQL Server on 'localhost' (10061)
Starte ich das MySQL Admin Tool, so bleibt die Ampel rot.
Nun habe ich festgestellt, dass der MySQL Dienst laut W2K zwar automatisch starten soll, dies aber nicht tut. Will ich dies nun von Hand nachholen, so versucht Windows diesen zu starten, es erscheint jedoch nach kurzer Zeit die Fehlermeldung:
Der Dienst "MySQL" auf "Lokaler Computer" konnte nicht gestartet werden.
Fehler 1067: Der Prozess wurde unerwartet beendet.

Was mache ich falsch? Bzw. was habe ich vergessen?
Ich bitte um Eure Mithilfe! Vielen Dank!

Schöne Grüße!

 
TBT
19-02-2003, 15:53 
 
Haste mit dem MySQL Admin Tool schon eine my.ini auf c:\ erzeugt ?

 
talker
19-02-2003, 16:19 
 
Hi,

danke der Nachfrage!
Die my.ini steht bei mir in c:\winnt.
Damit funktionierte das letztes Semester ja auch noch. Nach dem stöbern hier im Forum habe ich die my.ini gestern mal umbenannt und er hat mir beim erneuten Aufruf von winmysqladmin eine neue my.ini wieder in c\winnt erzeugt!?

Grüße

 
TBT
19-02-2003, 16:23 
 
bei meinen Installationen steht die immer unter c:\

 
talker
19-02-2003, 17:01 
 
Hallo TBT,

vielen Dank für Deine Bemühungen! Mein Server läuft wieder. Bitte nicht fragen warum! Ich weiß es nicht. Ich habe alles neu installiert, nicht zum ersten mal - habe das gestern auch schon getan, die my.ini gelöscht und jetzt funktioniert es wieder.
Die my.ini ist allerdings wieder im c:\winnt - Verzeichnis gelandet!?
Also nochmals vielen Dank!

Schöne Grüße
talker


Alle Zeitangaben in WEZ +2. Es ist jetzt 03:56 Uhr.