PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr

PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr (https://www.php-resource.de/forum/)
-   Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) (https://www.php-resource.de/forum/fragen-zu-installation-and-konfiguration-lamp-wamp-and-co/)
-   -   Suse 7.2 Prof. -> Updaten von PHP4.0.4 auf PHP 4.1 (https://www.php-resource.de/forum/fragen-zu-installation-and-konfiguration-lamp-wamp-and-co/6856-suse-7-2-prof-updaten-von-php4-0-4-auf-php-4-1-a.html)

dobber 25-04-2002 15:05

Suse 7.2 Prof. -> Updaten von PHP4.0.4 auf PHP 4.1
 
Hallo Fachleute!

Ich habe folgendes Problem:

Hier steht ein Apache-Webserver unter Suse 7.2 Prof. mit vorinstalliertem Apache und PHP 4.0.4! Ich will nun ein Update ausführen auf 4.1, leider weiss ich nicht wie! Alle "./configure"-Ausführungen wurde zwar durchgeführt. Auch bei "make" und "make install" wurde nicht gemosert. Aber wenn ich mir die Version anschaue (nach Restart von Apache) erscheint immer noch die alte Version!

Kennt jmd. ein Tut. o.ä., wie man ein Update durchführen kann?

Ich würde glatt vor Freude meinen Kaffee umschütten...

SeTom 26-04-2002 14:22

Zuerst solltest du mal feststellen ob PHP als Module geladen wird oder statisch. Wenn es Statisch geladen wird mußt du den Apache auch neu bauen.
Sonst versuch es einmal mit. ./configure --with-apxs=/usr/local/apache/current/bin/apxs (das mußt du halt gegen deinen Apache-Pfad + /bin/apxs ersetzen) ....

dobber 02-05-2002 12:39

wenn ich das richtig gesehen habe, installiert suse apache als dso! ich finde jedoch kein apxs oder ähnliches. andere config-versuche (with-apache oder with-httpd) schlugen auch fehl. bin ich einfach zu doof, oder hat suse das gut versteckt...


Alle Zeitangaben in WEZ +2. Es ist jetzt 19:49 Uhr.

Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.0
[c] ebiz-consult GmbH & Co. KG