php-resource



Zurück   PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr > Entwicklung > PHP Developer Forum
 

Login

 
eingeloggt bleiben
star Jetzt registrieren   star Passwort vergessen
 

 

 


PHP Developer Forum Hier habt ihr die Möglichkeit, eure Skriptprobleme mit anderen Anwendern zu diskutieren. Seid so fair und beantwortet auch Fragen von anderen Anwendern. Dieses Forum ist sowohl für ANFÄNGER als auch für PHP-Profis! Fragen zu Laravel, YII oder anderen PHP-Frameworks.

Antwort
 
LinkBack Themen-Optionen Thema bewerten
  #1 (permalink)  
Alt 28-03-2008, 02:41
chrigu99
 Registrierter Benutzer
Links : Onlinestatus : chrigu99 ist offline
Registriert seit: Oct 2003
Ort: Schweiz
Beiträge: 119
chrigu99 ist zur Zeit noch ein unbeschriebenes Blatt
Standard GD Support

Hi zusammen

Hab bei mir PHP5 am laufen, inklusive dem Paket php5-gd. phpinfo() meint auch, dass GD-Support enabled ist.
Trutzdem meint PHP dass der Aufruf von imagefilter() ein Call to undefined function ist.
Laut PHP Doku ist diese Funktion ab PHP5 vorhanden.
Jemand ne Idee?

Besten Dank schonmal

Gruss

Chris
__________________
Welch triste Epoche, in der es leichter ist, ein Atom zu zertrümmern als ein Vorurteil!

cubetech in Bern » Webdesign, Infrastruktur, Social Media, VoIP
Mit Zitat antworten
  #2 (permalink)  
Alt 28-03-2008, 11:58
Shurakai
 Master
Links : Onlinestatus : Shurakai ist offline
Registriert seit: May 2004
Ort: Bergisch Gladbach
Beiträge: 3.084
Shurakai ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Zitat:
Zitat ausm Manual
Note: This function is only available if PHP is compiled with the bundled version of the GD library.
Schau mal bei imgfilter den 1. (also obersten) User-Note an. Das sollte dir helfen.
Mit Zitat antworten
  #3 (permalink)  
Alt 28-03-2008, 12:00
Kropff
  Administrator
Links : Onlinestatus : Kropff ist offline
Registriert seit: Mar 2002
Ort: Köln
Beiträge: 11.722
Kropff befindet sich auf einem aufstrebenden Ast
Standard

@shurakai
leider läuft dein link ins leere

gruß
peter
__________________
Nukular, das Wort ist N-u-k-u-l-a-r (Homer Simpson)
Meine Seite
Mit Zitat antworten
  #4 (permalink)  
Alt 28-03-2008, 12:02
chrigu99
 Registrierter Benutzer
Links : Onlinestatus : chrigu99 ist offline
Registriert seit: Oct 2003
Ort: Schweiz
Beiträge: 119
chrigu99 ist zur Zeit noch ein unbeschriebenes Blatt
Standard

@ Shurakai:

Wenn PHP nicht bereits mit GD laufen würde, dann würde phpinfo() auch nicht melden dass GD-Support enabled ist (meiner Meinung nach)...
Trotzdem danke!
__________________
Welch triste Epoche, in der es leichter ist, ein Atom zu zertrümmern als ein Vorurteil!

cubetech in Bern » Webdesign, Infrastruktur, Social Media, VoIP

Geändert von chrigu99 (28-03-2008 um 12:22 Uhr)
Mit Zitat antworten
  #5 (permalink)  
Alt 28-03-2008, 12:33
jahlives
 Master
Links : Onlinestatus : jahlives ist offline
Registriert seit: Jun 2004
Ort: Hooker in Kernel
Beiträge: 8.279
jahlives ist zur Zeit noch ein unbeschriebenes Blatt
Standard

GD enabled sagt nix darüber aus ob es sich bei der GD Version um die "gebundelte" Version handelt, die mit PHP geliefert wurde. Und genau diese Version setzt die Funktion aber voraus.
Hast du schonmal gd_info() benutzt und dir die Version genau angeschaut?
__________________
Gutes Tutorial | PHP Manual | MySql Manual | PHP FAQ | Apache | Suchfunktion für eigene Seiten

"An error does not become truth by reason of multiplied propagation, nor does truth become error because nobody sees it."
Mohandas Karamchand Gandhi (Mahatma Gandhi) (Source)
Mit Zitat antworten
  #6 (permalink)  
Alt 28-03-2008, 13:29
chrigu99
 Registrierter Benutzer
Links : Onlinestatus : chrigu99 ist offline
Registriert seit: Oct 2003
Ort: Schweiz
Beiträge: 119
chrigu99 ist zur Zeit noch ein unbeschriebenes Blatt
Standard

PHP-Code:
array(12) { 
[
"GD Version"]=>  string(13"2.0 or higher" 
["FreeType Support"]=>  bool(true
[
"FreeType Linkage"]=>  string(13"with freetype" 
["T1Lib Support"]=>  bool(true
[
"GIF Read Support"]=>  bool(true
[
"GIF Create Support"]=>  bool(true
[
"JPG Support"]=>  bool(true
[
"PNG Support"]=>  bool(true
[
"WBMP Support"]=>  bool(true)
[
"XPM Support"]=>  bool(false
[
"XBM Support"]=>  bool(false
[
"JIS-mapped Japanese Font Support"]=>  bool(false

Dies gibt gd_info() aus...

Grüsse
__________________
Welch triste Epoche, in der es leichter ist, ein Atom zu zertrümmern als ein Vorurteil!

cubetech in Bern » Webdesign, Infrastruktur, Social Media, VoIP
Mit Zitat antworten
  #7 (permalink)  
Alt 28-03-2008, 15:42
jahlives
 Master
Links : Onlinestatus : jahlives ist offline
Registriert seit: Jun 2004
Ort: Hooker in Kernel
Beiträge: 8.279
jahlives ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Im Beispiel zu dieser Fkt im Manual wird aber
Zitat:
string(24) "bundled (2.0 compatible)"
angegeben. Also vermute ich mal, dass deine GD Lib nicht jener entspricht, die mit PHP geliefert wurde...
__________________
Gutes Tutorial | PHP Manual | MySql Manual | PHP FAQ | Apache | Suchfunktion für eigene Seiten

"An error does not become truth by reason of multiplied propagation, nor does truth become error because nobody sees it."
Mohandas Karamchand Gandhi (Mahatma Gandhi) (Source)
Mit Zitat antworten
  #8 (permalink)  
Alt 28-03-2008, 16:30
chrigu99
 Registrierter Benutzer
Links : Onlinestatus : chrigu99 ist offline
Registriert seit: Oct 2003
Ort: Schweiz
Beiträge: 119
chrigu99 ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Das Ganze läuft auf einem Debian-ähnlichem System (Ubuntu, auf dem Server sowie auch bei mir zu Hause) und da habe ich einfach im Paketmanager das Paket "php5-gd - GD module for php5" installiert. In den Konfigurationsdateien wird auch die gd.so ohne Ausgabe eines Fehlers eingebunden. Also nehme ich jetzt mal an, dass dies die richtige Version ist (Man korrigiere mich). Wo kann ich noch ansetzen?

Anmerkung: Mit früheren PHP-Versionen von Version 5 ist es mal gelaufen... Ich kann Euch aber beim besten Willen nicht sagen, was geändert wurde, ausser den regelmässigen Updates.
__________________
Welch triste Epoche, in der es leichter ist, ein Atom zu zertrümmern als ein Vorurteil!

cubetech in Bern » Webdesign, Infrastruktur, Social Media, VoIP

Geändert von chrigu99 (28-03-2008 um 16:32 Uhr)
Mit Zitat antworten
  #9 (permalink)  
Alt 28-03-2008, 22:01
DerSchonWieder
 Newbie
Links : Onlinestatus : DerSchonWieder ist offline
Registriert seit: Feb 2008
Beiträge: 74
DerSchonWieder ist zur Zeit noch ein unbeschriebenes Blatt
Standard

GD ist in PHP5 schon integriert. (Bundle)

Wenn du GD aber extra installierst, ist es kein Bundle mehr.


Also nur PHP5 installieren .
Mit Zitat antworten
  #10 (permalink)  
Alt 30-03-2008, 21:42
chrigu99
 Registrierter Benutzer
Links : Onlinestatus : chrigu99 ist offline
Registriert seit: Oct 2003
Ort: Schweiz
Beiträge: 119
chrigu99 ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Danke für den Tipp. Leider nutzlos...
Ich weiss wirklich nicht mehr wo ansetzen?
__________________
Welch triste Epoche, in der es leichter ist, ein Atom zu zertrümmern als ein Vorurteil!

cubetech in Bern » Webdesign, Infrastruktur, Social Media, VoIP
Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


PHP News

ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlicht
ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlichtDie bekannte Marktplatzsoftware ebiz-trader ist in der Version 7.5.0 veröffentlicht worden.

28.05.2018 | Berni

Wissensbestand in Unternehmen
Wissensbestand in UnternehmenLebenslanges Lernen und Weiterbilden sichert Wissensbestand in Unternehmen

25.05.2018 | Berni


 

Aktuelle PHP Scripte

ADSMAN V3 - Werbe-Manager ansehen ADSMAN V3 - Werbe-Manager

ADSMAN V3 - mehr als nur ein Bannermanager! Banner, Textanzeigen und PagePeel Manager! Mit ADSMAN PRO haben Sie die Marketinglösung für eine effektive und effiziente Werbeschaltung mit messbaren Ergebnissen. Unterstützt werden Bannerformate in beliebi

25.10.2018 virtualsystem | Kategorie: PHP/ Bannerverwaltung
PHP News und Artikel Script V2

News schreiben, verwalten, veröffentlichen. Dies ist jetzt mit dem neuen PHP News & Artikel System von virtualsystem.de noch einfacher. Die integrierte Multi-User-Funktion und der WYSIWYG-Editor (MS-Office ähnliche Bedienung) ermöglichen...

25.10.2018 virtualsystem | Kategorie: PHP/ News
Top-Side Guestbook

Gästebuch auf Textbasis (kein MySQL nötig) mit Smilies, Ip Sperre (Zeit selbst einstellbar), Spamschutz, Captcha (Code-Eingabe), BB-Code, Hitcounter, Löschfunktion, Editierfunktion, Kommentarfunktion, Kürzung langer Wörter, Seiten- bzw. Blätterfunktion, V

22.10.2018 webmaster10 | Kategorie: PHP/ Gaestebuch
 Alle PHP Scripte anzeigen

Alle Zeitangaben in WEZ +2. Es ist jetzt 14:09 Uhr.