php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
$_SERVER[HTTP_REFERER] - ... aber nicht immer?


 
->X³<-
25-05-2003, 16:51 
 
Hallo,

Ist es normal das es bei

$_SERVER['HTTP_REFERER']

auch mal keinen Inhalt (leer) gibt?
Und wenn ja, warum? :dontknow:



Gruß

 
TobiaZ
25-05-2003, 16:52 
 
Weil der vom Browser geliefert wird. Mansche Browser verändern diesen oder lassen Ihn leer.

Daher kann man sich auf den Referer nicht verlassen. Never trust incomeing data!

 
->X³<-
25-05-2003, 16:56 
 
... das hab ich mir gedacht ...

:D

Es gibt da Banner-Scripte die angeblich ohne Sub-Codes auskommen.
Um aber die unterschiedliche Herkunft zu erkennen wird da doch der Referer genutzt, ... denke ich mal.


 
->X³<-
25-05-2003, 17:39 
 
*lol*

Die Startseite kommt mit dem

$_SERVER['HTTP_REFERER']

im Betreff wohl nicht klar *g*

siehe Startseite -> Aktuelle Beiträge im Forum:


*'n Bug gefunden*



 
TobiaZ
25-05-2003, 17:42 
 
wo meinst du genau? (link)
habs gefunden. meintest die php-resource.de startseite

http://www.php-resource.de/forum/index.php?s= - ... aber nicht immer?

 
->X³<-
25-05-2003, 17:45 
 
Na, Startseite unten Rechts, bei der Auflistung der aktuellsten Foren-Einträge...
sticht doch gleich ins Auge....



 
TobiaZ
25-05-2003, 17:45 
 
^^

 
Moqui
25-05-2003, 21:51 
 
was ist $_SERVER["HTTP_REFERER"] ???

in meiner phpinfo() steht das net drin in den vars...

 
TobiaZ
25-05-2003, 21:53 
 
dann guvk mal im Manual! Oder probiers aus!

 
Moqui
25-05-2003, 21:55 
 
Original geschrieben von TobiaZ
dann guvk mal im Manual! Oder probiers aus!

mit so vielen Buchstaben hättest du mir auch sagen können, was es ist...

also danke für deine Bemühungen

 
TobiaZ
25-05-2003, 21:56 
 
kein Problem. :D

nee, aber das ist ne einfache Prinzipsache.


Alle Zeitangaben in WEZ +2. Es ist jetzt 06:51 Uhr.