php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
PHP Dateien werden nicht angezeigt


 
schlagoschluedi
31-01-2006, 16:37 
 
Hallo,

sorry falls ich mit diesem Thema vielleicht nicht ganz richtig hier bin, aber ich hoffe, daß PHP-Entwickler möglicherweise schon einmal von so etwas skurilem gehört haben.

Also ich habe bei einem Anwender-PC ein Problem, daß der Browser (IE) keine PHP4-Dateien anzeigt. Und das von verschiedenen Domains, die bei unterschiedlichen Providern gehostet werden.

Jetzt kam noch erschwerend hinzu, daß auch PHP-Dateien ab und an nicht angezeigt werden. Bei 95% der PHP-Dateien geht alle prima, nur bei 2 mehrfach erprobten hapert es.

Bei vier unterschiedlichsten PCs anderer Firmen, werden die Dateien ordentlich ausgeführt. Demnach kann es doch nur an einer popeligen Einstellung am Rechner liegen.

Ist jemand etwas dazu bekannt?

Herzlichen Dank für jedwede Hilfe

 
jahlives
31-01-2006, 16:41 
 
PHP läuft auf'm Server und sollte sich afaik einen Dreck um den verwendeten Browser scheren
Mir wäre keine clientseitige Einstellung bekannt, die die Anzeige von korrektem PHP Code verhindern würde (ich denke das geht schon prizipiell nicht)

Gruss

tobi

 
schlagoschluedi
31-01-2006, 16:51 
 
jetzt nicht viel geholfen. Nur weil Du dir das nicht vorstellen kannst, ist das Problem dennoch existent.

Man lernt ja nie aus - gell?

Trotzdem Danke für deine Rückmeldung

 
onemorenerd
31-01-2006, 17:02 
 
Welchen Content-Type geben denn die Scripte bzw. der Server an? Wie sollte der fragliche Browser damit umgehen?

 
jahlives
31-01-2006, 17:05 
 
Jetzt nochmals zum rekaplitulieren:
Ein php File wird geöffnet und der Parser geht drüber. Er bearbeitet alles und gibt am Ende pures HTML an den Browser zurück.
Kriegst du denn einfach eine weisse Seite zurück oder wie ? Wenn ja, Rechtsklick und Quellcode anschauen.
Ist der HMTL Code überhaupt validiert ?
Wie gesagt php ist serverseitig und wird komplett auf dem Server ausgeführt.
Werden allenfalls Zugriffe auf PHP Dateien irgendwie gefiltert (Router, FireWall etc) ?

Gruss

tobi

 
schlagoschluedi
31-01-2006, 17:13 
 
Hallo,

in allen Scripten steht das gleiche
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Von den 4 Dateien wird eines korrekt ausgeführt und die andere nicht (an den besagten seltsamen PCs).
An meinem PC läuft alles perfekt.


=> Kann es also nicht daran liegen.

Viele Grüße

 
onemorenerd
31-01-2006, 17:18 
 
Ich meinte eigentlich die HTTP-Header.

 
schlagoschluedi
17-02-2006, 09:47 
 
Für alle, die es interessiert:

es lag am Norton-Internetsecurity, und zwar genauer am PopUp-Blocker.

Ist der aktiviert, werden Scripte nicht korrekt ausgeführt. Das geht vom Seiten komplett nicht anzeigen bis zu falscher Ausführung einer Substr-Funktion.

Also entweder ausschalten oder ganz auf den Norton verzichten.

Viele Grüße

Petra

 
jahlives
17-02-2006, 09:51 
 
Das geht vom Seiten komplett nicht anzeigen bis zu falscher Ausführung einer Substr-Funktion.
Dann bitte mal Norton um eine Stellungsnahme wie die es schaffen mit ihrer FW die Ausführung einer serverseitigen Funktion zu unterdrücken bzw zur falschen Ausführung zu zwingen. :confused:
Kann es denn sein, dass es eine JS Substr Fkt ist ?

Gruss

tobi

- -

Alle Zeitangaben in WEZ +2. Es ist jetzt 20:05 Uhr.