php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
IE6 - Session wird nicht aufgebaut...


 
The_Hara
26-05-2009, 23:08 
 
Hallo...
ich habe seit einiger Zeit das problem das beim testen meines CMS im IE6 keine Sessions aufgebaut werden...

IE7, Firefox, IE8 funktioniert wunderbar ohne probleme...
nur der IE6 macht probleme...

mein Login Snippet:
if(isset($_POST['submit'])) {

$email = $_POST['email'];
$pass = sha1($_POST['passwort']);
if(isset($_POST['oldref'])) {
$oldref = $_POST['oldref'];
}
if(isset($_POST['oldrefa'])) {
$oldref_ad = $_POST['oldrefa'];
}
unset($_POST);

$user = $db->query_first('
SELECT *
FROM ' . $db->prefix . '_user
WHERE
email = \'' . $email . '\' and
passwort = \'' . $pass . '\'
');

unset($pass);

if(isset($user->id)) {

$_SESSION['userid'] = $user->id;
$_SESSION['ip'] = ip2long($_SERVER['REMOTE_ADDR']);
$db->query('UPDATE ' . $db->prefix . '_user SET lastlogin = UNIX_TIMESTAMP() WHERE id = ' . $user->id);
setcookie("cmx_login_userid", $user->id, time() + 60*60*24*365);
setcookie("cmx_login_pass", $user->passwort, time() + 60*60*24*365);

$ref_string = $_SERVER['HTTP_REFERER'];
$ref_string = str_replace('http://','',$ref_string);
$r_string = explode('/',$ref_string);

$tmp->add('error',error_output('logged','','./'.$r_string['1']));
$tmp->add("content", $tmp->load('error','success'));

} else {

$tmp->add('error',error_output('userpw'));
$tmp->add("content", $tmp->load('error','fail'));

}

}

 
asp2php
26-05-2009, 23:19 
 
Und? Was hast du denn schon unternommen? session_id schon überprüft, ob es sich dauernd ändert? und was soll denn unset(...) bewirken? Wozu soll das gut sein? Mach dich mal schlau über SQL-Injection!


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:06 Uhr.