php-resource



Zurück   PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr > Entwicklung > Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.)
 

Login

 
eingeloggt bleiben
star Jetzt registrieren   star Passwort vergessen
 

 

 


Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) Probleme, Apache mit PHP oder MySQL zum Laufen zu bringen? Anpassung an .htaccess, httpd.conf oder php.ini funktionieren nicht? In diesem Forum könnt ihr eure Erfahrungen austauschen.

Antwort
 
LinkBack Themen-Optionen Thema bewerten
  #1 (permalink)  
Alt 02-01-2011, 16:50
pascal007
 Registrierter Benutzer
Links : Onlinestatus : pascal007 ist offline
Registriert seit: Jul 2006
Beiträge: 257
pascal007 ist zur Zeit noch ein unbeschriebenes Blatt
pascal007 eine Nachricht über ICQ schicken
Unhappy [htaccess] modReqrite, RegEx und GET-Paramter

Hallo

Ich habe ein Problem. Ich nutze folgende .htaccess Datei zur Umleitung (Auszug):

Code:
RewriteRule aboutme$ articles.php?module=view&article=xyz

# articles.php
RewriteRule articles/category/(\d+)-(.+)$ articles.php?module=category&category=$1
RewriteRule articles/article/(\d+)-(.+)$ articles.php?module=view&article=$1
Auf meinem XAMPP-Testserver lokal läuft das wunderbar. Aber wenn ich das ganze auf mein Webspace hochschiebe, dann werden bei den RegEx-Umleitungen keinerlei GET-Parameter übergeben.

Bei der ersten Umleitung ohne RegEx (aboutme) funktioniert alles tiptop und die GET-Parameter werden mitgesendet. Die Umleitung auf das richige PHP-Script funktioniert, nur eben ohne GET-Parameter.

Kann mir jemand sagen was ich falsch mache? Oder liegt das an meinem Webspace bzw dessen Konfiguation?

Wäre euch über Hilfe sehr dankbar .
Mit Zitat antworten
  #2 (permalink)  
Alt 02-01-2011, 17:49
AmicaNoctis
  Moderatorin
Links : Onlinestatus : AmicaNoctis ist offline
Registriert seit: Jul 2009
Beiträge: 5.709
Blog-Einträge: 9
AmicaNoctis sorgt für eine eindrucksvolle AtmosphäreAmicaNoctis sorgt für eine eindrucksvolle Atmosphäre
Standard

Hallo,

überprüf als erstes die Pfade. Das ist der häufigste Grund, warum lokale Systeme auf einem Webspace plötzlich nicht mehr arbeiten.

Hast du RewriteEngine auf On gesetzt?

Falls es nicht hilft, bitte die kmplette .htaccess posten.

Gruß,

Amica
__________________
Hast du die Grundlagen zur Fehlersuche gelesen? Hast du Code-Tags benutzt?
Hast du als URL oder Domain-Beispiele example.com, example.net oder example.org benutzt?
Super, danke!
Mit Zitat antworten
  #3 (permalink)  
Alt 02-01-2011, 18:06
pascal007
 Registrierter Benutzer
Links : Onlinestatus : pascal007 ist offline
Registriert seit: Jul 2006
Beiträge: 257
pascal007 ist zur Zeit noch ein unbeschriebenes Blatt
pascal007 eine Nachricht über ICQ schicken
Standard

Ja die RewriteEngine habe ich natürlich auf ON gestellt. Falsche Pfade können es nicht sein, denn die Pfade an und für sich werden immer korrekt aufgerufen. Nur die GET-Parameter werden den Pfaden nicht mitgegeben.

Die ganze htaccess sieht so aus:

Code:
RewriteEngine On
RewriteBase /home/www/web51/html/v2

# navigation
RewriteRule newswall$ newswall.php
RewriteRule aboutme$ articles.php?module=view&article=xyz
RewriteRule articles$ articles.php
RewriteRule guestbook$ guestbook.php
RewriteRule links$ links.php
RewriteRule impressum$ impressum.php
RewriteRule register$ register.php

# gallery.php
RewriteRule gallery$ gallery.php
RewriteRule gallery/album/(\d+)-(.+)$ gallery.php?module=album&album=$1
RewriteRule gallery/picture/(.+)$ gallery.php?module=getpicture&path=$1
RewriteRule gallery/thumb/(\d+)/(.+)$ gallery.php?module=getthumb&path=$2&size=$1

# articles.php
RewriteRule articles/category/(\d+)-(.+)$ articles.php?module=category&category=$1
RewriteRule articles/article/(\d+)-(.+)$ articles.php?module=view&article=$1

#links.php
RewriteRule links/redirect/(\d+)$ links.php?module=redirect&link=$1
Mit Zitat antworten
  #4 (permalink)  
Alt 02-01-2011, 18:21
AmicaNoctis
  Moderatorin
Links : Onlinestatus : AmicaNoctis ist offline
Registriert seit: Jul 2009
Beiträge: 5.709
Blog-Einträge: 9
AmicaNoctis sorgt für eine eindrucksvolle AtmosphäreAmicaNoctis sorgt für eine eindrucksvolle Atmosphäre
Standard

Okay, und $_GET ist nach der Umleitung komplett leer? Bitte mal mit var_dump prüfen.
__________________
Hast du die Grundlagen zur Fehlersuche gelesen? Hast du Code-Tags benutzt?
Hast du als URL oder Domain-Beispiele example.com, example.net oder example.org benutzt?
Super, danke!
Mit Zitat antworten
  #5 (permalink)  
Alt 02-01-2011, 18:27
pascal007
 Registrierter Benutzer
Links : Onlinestatus : pascal007 ist offline
Registriert seit: Jul 2006
Beiträge: 257
pascal007 ist zur Zeit noch ein unbeschriebenes Blatt
pascal007 eine Nachricht über ICQ schicken
Standard

Ja ist es leider .

Code:
array(0) { }
Mit Zitat antworten
  #6 (permalink)  
Alt 02-01-2011, 18:28
AmicaNoctis
  Moderatorin
Links : Onlinestatus : AmicaNoctis ist offline
Registriert seit: Jul 2009
Beiträge: 5.709
Blog-Einträge: 9
AmicaNoctis sorgt für eine eindrucksvolle AtmosphäreAmicaNoctis sorgt für eine eindrucksvolle Atmosphäre
Standard

Hast du eine phpinfo-Seite auf dem Webspace? (Ein Script, in dem nur das steht:
PHP-Code:
<?php phpinfo(); ?>
)
__________________
Hast du die Grundlagen zur Fehlersuche gelesen? Hast du Code-Tags benutzt?
Hast du als URL oder Domain-Beispiele example.com, example.net oder example.org benutzt?
Super, danke!
Mit Zitat antworten
  #7 (permalink)  
Alt 02-01-2011, 18:35
pascal007
 Registrierter Benutzer
Links : Onlinestatus : pascal007 ist offline
Registriert seit: Jul 2006
Beiträge: 257
pascal007 ist zur Zeit noch ein unbeschriebenes Blatt
pascal007 eine Nachricht über ICQ schicken
Standard

Hab ich ja, kannst es dir ja mal anschauen:

phpinfo()
Mit Zitat antworten
  #8 (permalink)  
Alt 02-01-2011, 18:56
AmicaNoctis
  Moderatorin
Links : Onlinestatus : AmicaNoctis ist offline
Registriert seit: Jul 2009
Beiträge: 5.709
Blog-Einträge: 9
AmicaNoctis sorgt für eine eindrucksvolle AtmosphäreAmicaNoctis sorgt für eine eindrucksvolle Atmosphäre
Standard

Ich vermute, es liegt daran, dass dein PHP auf CGI läuft und nicht wie üblich als Apache Modul oder zumindest als FastCGI. Findest du die übergebenen Get-Parameter in $_SERVER["REQUEST_URI"] oder sind die dort auch weg?

Edit: Nee, das ist es nicht. Bei http://timesplinter.ch/info.php?foo=bar kommen sie auch an. Der Server ist wirklich komisch konfiguriert und gibt die Get-Parameter beim Rewriting nicht weiter.

Edit2: Versuch mal, an jede Regel ein [R] anzuhängen. Ist zwar ne blöde Lösung, sollte aber erstmal helfen, bis dein Provider sich zu dem Problem geäußert hat.

Beispiel:
Code:
# navigation
RewriteRule newswall$ newswall.php [R]
RewriteRule aboutme$ articles.php?module=view&article=xyz [R]
RewriteRule articles$ articles.php [R]
...
__________________
Hast du die Grundlagen zur Fehlersuche gelesen? Hast du Code-Tags benutzt?
Hast du als URL oder Domain-Beispiele example.com, example.net oder example.org benutzt?
Super, danke!

Geändert von AmicaNoctis (02-01-2011 um 19:07 Uhr)
Mit Zitat antworten
  #9 (permalink)  
Alt 02-01-2011, 20:07
pascal007
 Registrierter Benutzer
Links : Onlinestatus : pascal007 ist offline
Registriert seit: Jul 2006
Beiträge: 257
pascal007 ist zur Zeit noch ein unbeschriebenes Blatt
pascal007 eine Nachricht über ICQ schicken
Standard

Das nützt leider auch nichts . Aber ich werde in dem Fall den Provider mal anschreiben, der weiss sicher Rat, wenn es sich wirklich um ein Problem von ihm handelt .

Danke auf jeden Fall für deine Hilfe .
Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
[REGEX] Mod rewrite && .htaccess Timo Trallala Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) 2 17-08-2006 11:41
[REGEX] Problem mit Regex in .htaccess daniel987 Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) 2 21-06-2005 00:10
unbekannter img-paramter Kropff HTML, JavaScript, AJAX, jQuery, CSS, Bootstrap, LESS 5 20-04-2005 20:49
[REGEX] Funktionsaufruf in pregg_replace - 2. Paramter Crake PHP Developer Forum 11 28-03-2005 11:34
Fehler: /.htaccess: Regex could not be compiled eldiavolo666 Fragen zu Installation & Konfiguration (LAMP, WAMP & Co.) 2 01-03-2005 19:02

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


PHP News

ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlicht
ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlichtDie bekannte Marktplatzsoftware ebiz-trader ist in der Version 7.5.0 veröffentlicht worden.

28.05.2018 | Berni

Wissensbestand in Unternehmen
Wissensbestand in UnternehmenLebenslanges Lernen und Weiterbilden sichert Wissensbestand in Unternehmen

25.05.2018 | Berni


 

Aktuelle PHP Scripte

PHP Server Monitor

PHP Server Monitor ist ein Skript, das prüft, ob Ihre Websites und Server betriebsbereit sind.

11.09.2018 Berni | Kategorie: PHP/ Security
PHP WEB STATISTIK ansehen PHP WEB STATISTIK

Die PHP Web Statistik bietet Ihnen ein einfach zu konfigurierendes Script zur Aufzeichnung und grafischen und textuellen Auswertung der Besuchern Ihrer Webseite. Folgende zeitlichen Module sind verfügbar: Jahr, Monat, Tag, Wochentag, Stunde Folgende son

28.08.2018 phpwebstat | Kategorie: PHP/ Counter
Affilinator - Affilinet XML Produktlisten Skript

Die Affilinator Affilinet XML Edition ist ein vollautomatisches Skript zum einlesen und darstellen der Affili.net (Partnerprogramm Netzwerk) Produktlisten und Produktdaten. Im Grunde gibt der Webmaster seine Affilinet PartnerID ein und hat dann unmittelb

27.08.2018 freefrank@ | Kategorie: PHP/ Partnerprogramme
 Alle PHP Scripte anzeigen

Alle Zeitangaben in WEZ +2. Es ist jetzt 16:14 Uhr.