Grafik funktioniert nicht!

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Grafik funktioniert nicht!

    Hallo,
    ich habe SUSE SLES8 mit APACHE und PHP (4.2.2) installiert (über Yast)...
    Nun möchte ich Grafiken "anzeigen".
    Dies Funktioniert aber nicht!
    Auf einem anderem Rechner klappt es aber (mit dem gleichen Script).
    Was mir aufgelfallen ist, auf dem einem Rechner ist '--with-gd=shared'
    eingeschaltet (dort funktioniert es nciht).

    Kann das die Lösung sein? Kann ich das in der php.ini ändern, oder muß ich php neu installieren?

    Danke für eure hilfe;

    Thilly

  • #2
    installationsfrage! *VERSCHIEB*
    INFO: Erst suchen, dann posten! | MANUAL(s): PHP | MySQL | HTML/JS/CSS | NICE: GNOME Do | TESTS: Gästebuch | IM: Jabber.org |


    Kommentar


    • #3
      gd_info?

      Hallo,
      ich habe gerad mal ein wenig gestöbert...
      und das script:
      <?php
      var_dump(gd_info());
      ?>

      gefunden allerdings bekomme ich das zurück:
      Fatal error: Call to undefined function: gd_info() in /usr/local/htdocs/phpinfo_gd.php on line 2

      Heißt das GD ist nicht installiert?
      Im Yast habe ich alles installiert was mit GD "drin" stand.
      wenn ich

      ldd /usr/bin/php
      da findet er :
      libgd.so.4 => /usr/lib64/libgd.so.4 (0x0000010000952000)

      Kommentar


      • #4
        Heißt das GD ist nicht installiert?
        sieht so aus.

        mache mal phpinfo() in eine datei und rufe sie auf.

        wenn dort kein GD zu finden ist, ist sie nicht dabei.
        INFO: Erst suchen, dann posten! | MANUAL(s): PHP | MySQL | HTML/JS/CSS | NICE: GNOME Do | TESTS: Gästebuch | IM: Jabber.org |


        Kommentar


        • #5
          habe ich!
          es ist enabled.
          Die Abfrage von oben geht wohl mit der PHP Version nicht :-(

          Kommentar


          • #6
            Original geschrieben von thilly
            Die Abfrage von oben geht wohl mit der PHP Version nicht :-(
            ab version 4.3.0 geht es. -> (PHP 4 >= 4.3.0)

            http://de.php.net/manual/de/function.gd-info.php
            INFO: Erst suchen, dann posten! | MANUAL(s): PHP | MySQL | HTML/JS/CSS | NICE: GNOME Do | TESTS: Gästebuch | IM: Jabber.org |


            Kommentar


            • #7
              Richtig,
              aber ich habe leider kein PHP4.3 sondern 4.2.2.
              Sorry

              Kommentar


              • #8
                suche mal im forum ... Wurzel meine ich, hatte da mal was gebastelt, um dennoch an die daten bei php<4.3 dranzukommen.
                INFO: Erst suchen, dann posten! | MANUAL(s): PHP | MySQL | HTML/JS/CSS | NICE: GNOME Do | TESTS: Gästebuch | IM: Jabber.org |


                Kommentar


                • #9
                  Moin Leute,
                  hab' das gleiche Problem ( 'ne V. 4.2.2. und keine Grafikanzeige ), das gibts doch nich', hab glatt 2h am img rumgebastelt und fast verzweifelt , zum Glück gibst das Forum
                  suche mal im forum ... Wurzel meine ich, hatte da mal was gebastelt, um dennoch an die daten bei php<4.3 dranzukommen.
                  det hab ich gesucht aber nicht gefunden, wo finde ich den Beitrag
                  so long
                  McMurphy
                  "I don't want to belong to any club that would accept me as a member."

                  Groucho Marx

                  Kommentar

                  Lädt...
                  X