PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr

PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr (https://www.php-resource.de/forum/)
-   PHP Developer Forum (https://www.php-resource.de/forum/php-developer-forum/)
-   -   __DIR__ Problem, Unterschied zwischen 5.3 und 5.2 (https://www.php-resource.de/forum/php-developer-forum/101151-__dir__-problem-unterschied-zwischen-5-3-und-5-2-a.html)

sascha_h 04-02-2011 22:49

__DIR__ Problem, Unterschied zwischen 5.3 und 5.2
 
Hallo Leute,
ich bin ja immer noch dabei PHP und Mysql zu lernen, nun habe ich mir das Buch, "PHP 5.3 & Mysql 5.5" von "Stefan Reimers und Gunnar Thies" besorgt.
Nachdem meine Seite eigentlich schon so halbwegs läuft, wollte ich nun ein Mehrbenutzer System einführen. Dazu gibt es im Buch eine gute Anleitung. So hoffe ich.

Aber nun mein Problem. Zuhause auf dem Lokalen Mac mit Xampp und PHP 5.3. xx. läuft alles super.
Wenn ich das ganze nun zu meinem Provider hoch lade, der wie kann es anders sein, dort wird PHP 5.2.17 eingesetzt, bekomme ich immer diesen Fehler:

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /var/www/web2251/html/epsh/buch/index.php on line 6

Parse error: syntax error, unexpected T_STRING in /var/www/web2251/html/epsh/buch/index.php on line 6

Ich habe schon einiges Versuch aber ich bekomme es nicht umgeschrieben auf PHP 5.2, ich hoffe Ihr könnt mir helfen?

Also nun der Code:
Die Index.php im Root Verzeichnis.
PHP-Code:

<?php

require_once "common.php";

//HTML-Objekt erstellen
SystemHTML::printHead();
SystemHTML::printBody("background:grey;",false);

//Header
echo '<div style="width:100%;position:absolute;top:0px;left:0px;border-bottom:3px solid silver;background-image:url(images/titleBackground.png);background-repeat:repeat-x;">';
echo 
'<img style="padding:0px;margin:0px;" border="0" src="images/title.png">';
echo 
'</div>';
echo 
'<br /><br />';


//Navigation:
echo '<div style="background:white;float:left;padding:0px;margin:10px;border:1px solid gray;width:300px;">';
include 
'nav.php';
echo 
'</div>';
//Inhalt
echo '<div style="margin-left:330px;margin-top:10px;margin-right:10px;padding:0px;border:1px solid gray;">';
echo 
'<iframe name="scriptIFrame" id="scriptIFrame" style="height:700px;width:100%;margin:0px;padding:0px;background:white;" frameborder="no"></iframe>';
echo 
'</div>';

//Inhalt der Seite:
SystemHTML::printFoot();

?>

Nun die common.php im gleichen Verzeichnis.
PHP-Code:

<?php

#Projektpfade (Web und lokaler Pfad) 
include('paths.php');

#Datenbanksettings und weiter systemweite Einstellungen
require_once ('settings.php');

#Alle Basis-Klassen einbinden
require_once ('/inc/includeAllClasses.php');

#Datenbankobjekt erstellen (wenn nicht bereits erstellt)
if(!isset($GLOBALS['DB']))
    
$DB = new SystemDatabaseMySQL(DB_SERVER,DB_USER,DB_PASSWORD,DB_NAME,DB_PORT);

#global verfügbares Session-Objekt.
new SystemSessionHandler();

?>

Als nächstes die paths.php auch im gleichen Verzeichnis.
In dieser habe ich schon das "__DIR__" gegen "dirname(__FILE__) ersetzt.
PHP-Code:

<?php
//vor PHP 5.3: 
define('PROJECT_DOCUMENT_ROOT',dirname(__FILE__));
//seit PHP 5.3 define('PROJECT_DOCUMENT_ROOT',__DIR__);
//Projektname
$project str_replace($_SERVER['DOCUMENT_ROOT'], ''str_replace("\\""/",dirname(__FILE__)));

//Protokoll der Verbindung (HTTP oder HTTPS)
(!isset($_SERVER['HTTPS']) OR $_SERVER['HTTPS']=='off') ? $protocol 'http://' $protocol 'https://';
//PROJECT Pfad (für die Verwendung im Web)
define('PROJECT_HTTP_ROOT',$protocol.$_SERVER['HTTP_HOST'].$project);
?>

Original Paths.php
PHP-Code:

<?php
//vor PHP 5.3: define('PROJECT_DOCUMENT_ROOT',dirname(__FILE__));
//seit PHP 5.3
define('PROJECT_DOCUMENT_ROOT',__DIR__);
//Projektname
$project str_replace($_SERVER['DOCUMENT_ROOT'], ''str_replace("\\""/",__DIR__));

//Protokoll der Verbindung (HTTP oder HTTPS)
(!isset($_SERVER['HTTPS']) OR $_SERVER['HTTPS']=='off') ? $protocol 'http://' $protocol 'https://';
//PROJECT Pfad (für die Verwendung im Web)
define('PROJECT_HTTP_ROOT',$protocol.$_SERVER['HTTP_HOST'].$project);
?>

Die settings.php ber darin vermute ich keinen Fehler:
PHP-Code:

<?php

//Fehlerreporting
error_reporting(E_ALL);

//DEBUG-MODUS (wenn true, wird die Debug-Konsole angezeigt)
define('DEBUG',true);

//DATENBANKVERBINDUNGS-DATEN
define('DB_SERVER',"127.0.0.1");
define('DB_PORT',"3306");
define('DB_NAME',"usr_web2251_2");
define('DB_USER',"root");
define('DB_PASSWORD',"geheim");
define('HTML_TITLE',"PHP und MySQL");

//seit PHP 5.3 sollte die Zeitzone gesetzt werden
date_default_timezone_set('Europe/Berlin');

?>

und zum Schluss die includeAllClasses.php
PHP-Code:

<?php
//Namespace der Klasse
namespace System;

/**
 * Grundgerüst einer HTML-Seite.
 * 
 */

class HTML
{

    
/**
     * Erstellt den Kopf eines HTML-Dokuments.
     * 
     */
    
public static function printHead()
    {
        
//Workaround für Browser, die ansonsten Darstellungsprobleme 
        //mit UTF-8-codierten Seiten bekommen (bspw. Google Chrome)
        
header('Content-Type: text/html; charset=utf-8');
        
//Head ausgeben
        
echo '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">'."\r\n";
        echo 
'<html>'."\n";
        echo 
'<head>'."\n";
        echo 
'<title>'.HTML_TITLE.'</title>'."\n";
        echo 
'<meta http-equiv="content-type" content="text/html; charset=utf-8">'."\n";
        echo 
'<link rel="stylesheet" type="text/css" href="'.PROJECT_HTTP_ROOT.'/inc/css/default.css.php">'."\n";
        
//JQuery einbinden (für die Beispiele)
        
echo '<script src="'.PROJECT_HTTP_ROOT.'/extLibs/jquery/jquery-1.2.6.min.js"></script>';
        echo 
'<script src="'.PROJECT_HTTP_ROOT.'/extLibs/jquery/jquery-ui-personalized-1.6rc2.min.js"></script>';
        echo 
'<script src="'.PROJECT_HTTP_ROOT.'/inc/js/default.js" type="text/javascript"></script>';
        
    }

    
/**
     * Erstellt den 'Körper' eines HTML-Dokuments.
     * 
     * @param varchar Zusätzliche Cascading Stylesheets
     */
    
public static function printBody($css null,$withConsole true)
    {
        echo 
'</head>'."\n";
        echo 
'<body';
        if (
$css != null)
        {
            echo 
' style="'.$css.'"';
        }
        echo 
'>'."\n";
                
        
//DebugConsole einbinden (ist derselbe Namespace 'System\', kann also weggelassen werden)
        
if($withConsole AND DEBUG)DebugConsole::displayConsole();
            
    }
    
    
    
/**
     * Beendet ein HTML-Dokument.
     * 
     */
    
public static function printFoot()
    {

        echo 
'</body></html>';
    }

    
/**
     * Erstellt eine Überschrift für die Buch-CD
     * 
     * @param varchar Überschrifttext
     * @param boolean Mit oder ohne DEBUG-Leiste
     */
    
public static function printHeadline($headline)
    {
            
        echo 
'<div class="headline">';
        echo 
$headline;
        echo 
'</div>';

    }
    
    
/**
     * Erstellt lesbare Darstellungen von Arrays (für Buch-CD)
     * 
     */
    
public static function printArray($array = array())
    {
        return 
highlight_string(print_r($array,true),true);    
    }
    

}
?>

Ich habe schon alles mögliche Versucht, was in meinem Wissenbereich liegt.
Aber diesen Backslash, woher er auch immer kommen mag. Bekomme ich nicht weg. Daran liegt es aber auch garnicht. Das weiss ich ja. Irgendwas läuft anders, nur was, und wie bekomme ich es umgeschrieben auf PHP 5.2.17...

Gruss an alle Helfer!!!
Sascha

wahsaga 04-02-2011 23:08

Zitat:

Zitat von sascha_h (Beitrag 650816)
Aber diesen Backslash, woher er auch immer kommen mag. Bekomme ich nicht weg. Daran liegt es aber auch garnicht.

Wie kommst du darauf?
Die Meldung spricht eindeutig von einem unerwarteten \ - nur ist von dem in der gezeigten Datei nichts zu erkennen in Zeile 6.

Als erstes solltest du noch mal die Datei prüfen - und zwar die Version, die tatsächlich bei deinem Provider auf dem Server liegt. Vielleicht ist da beim Hochladen was schief gegangen.

Mit Versionsunterschieden zwischen 5.2 und 5.3 dürfte das jedenfalls ziemlich sicher absolut gar nichts zu tun haben.

AmicaNoctis 04-02-2011 23:41

Hallo,

Zitat:

Zitat von wahsaga (Beitrag 650817)
Mit Versionsunterschieden zwischen 5.2 und 5.3 dürfte das jedenfalls ziemlich sicher absolut gar nichts zu tun haben.

Das würde ich nicht unterschreiben. Wir wissen ja bereits, dass das Forum hier den Backslash im PHP-Code (ausgenommen Strings und Kommentare) entfernt. Es kann also sein, dass der TO qualifizierende Klassennamen verwendet, also in Wirklichkeit \SystemHTML dort steht.

@sascha: PHP kennt Namespaces erst ab Version 5.3. Davor ist der Backslash an der Stelle einfach ein ungültiges Zeichen. Klassen mit Namespaces sind daher einfach nicht möglich (abgesehen von Pseudo-Namespaces durch Präfigieren) und daher braucht/darf man vor PHP 5.3 auch keinen Backslash vor/in den Klassennamen haben.

Gruß,

Amica

h3ll 04-02-2011 23:45

$GLOBALS ist böse. Sowas verwendet man bei einer objektorientierten Programmierung überhaupt nicht und es ist auch absolut nicht notwendig.

wahsaga 04-02-2011 23:50

Zitat:

Zitat von AmicaNoctis (Beitrag 650818)
Das würde ich nicht unterschreiben. Wir wissen ja bereits, dass das Forum hier den Backslash im PHP-Code (ausgenommen Strings und Kommentare) entfernt. Es kann also sein, dass der TO qualifizierende Klassennamen verwendet, also in Wirklichkeit \SystemHTML dort steht.

Du hast Recht!

Beim Zitieren des Codes werden die Backslashes sogar angezeigt, da hätte ich genauer hinschauen sollen.

AmicaNoctis 04-02-2011 23:57

Zitat:

Zitat von wahsaga (Beitrag 650820)
Beim Zitieren des Codes werden die Backslashes sogar angezeigt.

Stimmt, also nicht bloß ein qualifizierender Name im Default-Namespace, sondern sogar System\HTML, also wirklich mit Namespaces. Darauf bin ich aber auch nicht gekommen, mal eher nachzusehen, was im Original-Code drin steht.

Wäre mal wieder eine Aufgabe für Berni, das Backslash-Verschlucken zu fixen ;)

onemorenerd 05-02-2011 03:21

OffTopic:
Zitat:

Zitat von AmicaNoctis (Beitrag 650821)
Wäre mal wieder eine Aufgabe für Berni, das Backslash-Verschlucken zu fixen ;)

Das Problem wird seit Jahren ignoriert. Mit Namespaces wirds echt akut, aber ich mach mir trotzdem keine Hoffnung.
Stellt euch schon mal drauf ein: Wir machen wir uns hier bald regelmäßig zum Depp!
Mal sehen wie lange es noch dauert, bis in anderen PHP-Foren über unsere Bugs gelacht wird.

sascha_h 05-02-2011 13:31

Guten Morgen,
ich habe es grad noch mal nachgeschaut, da fehlen in der Common.php wirklich ein paar Backslashes, und zwar hier:
$DB = new System\Database\MySQL(DB_SERVER,DB_USER,DB_PASSWORD,DB_NAME,DB_PORT);

Wenn ich das richtig verstehen kann ich also den Namenspace System\Database nicht verwenden, wie löse ich das dann?
Kann mir da jemand einen Tip geben? denn das ganze System basiert ja auf dem Namespace.

combie 05-02-2011 13:39

Zitat:

denn das ganze System basiert ja auf dem Namespace.
Das ältere Zend/Pear Benennungsschema verwenden.
Namespaces wurden erst mit 5.3 eingeführt.

Zend Framework: Documentation: Namens Konventionen - Zend Framework Manual
Manual :: Namens-Konventionen
Oder den Provider überreden.

sascha_h 05-02-2011 21:03

Ah, ok, dann werde ich mich mal damit beschäftigen. Provider Wechsel kommt leider erstmal nicht in Frage und wann der aufrüstet, wer weiss das schon...

Vielen Dank für eure Antworten.

AmicaNoctis 06-02-2011 00:56

Man kann aber mal fragen. Viele Provider bieten nämlich bereits PHP 5.3 an. Man muss es nur per -htaccess aktivieren. Das wird aber selten aktiv beworben, ich hab das bei meinem auch erst zufällig entdeckt und dann mal nachgefragt bzw. die Hilfedateien nochmal gelesen.


Alle Zeitangaben in WEZ +2. Es ist jetzt 20:52 Uhr.

Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.0
[c] ebiz-consult GmbH & Co. KG