GD mit PHP 4.3, Apache 1.3 und Windows - aber wie?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • GD mit PHP 4.3, Apache 1.3 und Windows - aber wie?

    Hallo

    Ich habe ein kleines Problem.

    Ich habe einen Script in welchem "ImageCreate($width, $height)" aufgerufen wird, eine Funktion von gd.
    Ich habe mir nun die neuste Version von gd heruntergeladen, weiss aber nicht, wie ich diese nun nutzen kann.
    Auch ein include von gd.c hat nichts gebracht.

    Fehler:

    Fatal error: Call to undefined function: imagecreate() in c:\projekte\coding\php\simplebar\gd-2.0.15\barchart.php on line 33

    Wie bekomm ich nun diese Funktion in mein php script rein?

    danke,

    holy

  • #2
    http://de.php.net/manual/de/function...etruecolor.php ?
    INFO: Erst suchen, dann posten! | MANUAL(s): PHP | MySQL | HTML/JS/CSS | NICE: GNOME Do | TESTS: Gästebuch | IM: Jabber.org |


    Kommentar


    • #3
      Wenn du GD-Unterstützung in Windows willst, musst du in deiner php.ini die Extension-Dir setzen auf das Unterverzeichnis extensions von deinem PHP-Ordner (z.B. D:\php\extensions isses bei mir) und dann das ; aus der Zeile
      ;extension=php_gd2.dll
      am Anfang wegmachen.
      Anschließend speichern, Apache neu starten und es sollte gehen.
      hopka.net!

      Kommentar


      • #4
        Hi,

        ich habe das gleiche Problem mit der GD-Library.

        Hab auch schon den die extensions_dir gesetzt und dann die php_gd2.dll aktiviert. Dann kackt mir aber der Apache(2) mit folgender Fehlermeldung ab.

        "Internal Server Error

        The server encountered an internal error or misconfiguration and was unable to complete your request."

        Wahscheinlich nur ein Anfänger-Fehler. Kann mir jemand helfen?

        Kommentar


        • #5
          Normalerweise kommt ne alert box, wenn was mit der extension nicht stimmt.. wenn du die gd wieder ausklammerst klappts wieder?
          _____________
          Ist das so? Scheinbar muss das so?! Oder ist es vielleicht viel leichter...
          Auch ich beantworte keine mails bei php problemen! Für das gibts ja das Forum!!

          Kommentar


          • #6
            holyfreak

            Lad dir doch die neuste php version als zip runter, das sind die files schon included
            _____________
            Ist das so? Scheinbar muss das so?! Oder ist es vielleicht viel leichter...
            Auch ich beantworte keine mails bei php problemen! Für das gibts ja das Forum!!

            Kommentar


            • #7
              Ja, die Alertbox kommt, solange ich nicht das extension_dir Verzeichnis angegeben habe. Sobald ich es angebe, bringt er mir den internen Fehler.
              Die Angabe mache ich so:

              extension_dir = "c:\web\php\extensions"

              Ist daran was falsch?
              In dem Ordner liegen die auch!

              Ich habe PHP Version 4.3.3

              Kommentar


              • #8
                extension_dir = ./extensions/

                und wenn dus so schreibst...
                _____________
                Ist das so? Scheinbar muss das so?! Oder ist es vielleicht viel leichter...
                Auch ich beantworte keine mails bei php problemen! Für das gibts ja das Forum!!

                Kommentar


                • #9
                  Nö, dann auch nicht

                  Kommentar


                  • #10
                    Dann die selbe fehler msg?
                    _____________
                    Ist das so? Scheinbar muss das so?! Oder ist es vielleicht viel leichter...
                    Auch ich beantworte keine mails bei php problemen! Für das gibts ja das Forum!!

                    Kommentar


                    • #11
                      Yep

                      Kommentar


                      • #12
                        Ich hatte au son stress

                        ...meine lösung war

                        neues php 4.3.3 ZIP archiv downgeloadet. Der alte php-ordner gelöscht, der neue von der zip ans selbe ort kopiert und alles lief bestens...

                        Nehm an du hast die .msi datei installiert...?
                        _____________
                        Ist das so? Scheinbar muss das so?! Oder ist es vielleicht viel leichter...
                        Auch ich beantworte keine mails bei php problemen! Für das gibts ja das Forum!!

                        Kommentar


                        • #13
                          Ich habs mal mit der auto-installation versucht. Hab gehofft das würde mir Stress ersparen

                          Kommentar


                          • #14
                            Musste nochmals lesen...habs beim 1sten mal auch übersehen...

                            msi... keine module
                            zip ... viele module
                            _____________
                            Ist das so? Scheinbar muss das so?! Oder ist es vielleicht viel leichter...
                            Auch ich beantworte keine mails bei php problemen! Für das gibts ja das Forum!!

                            Kommentar


                            • #15
                              Juhu,

                              hattest recht!!! Einfach nochmal runterladen und drüber klatschen!

                              Ach ja, hätt ich das mal lieber früher versucht!

                              Danke!!!

                              Kommentar

                              Lädt...
                              X