php-resource



Zurück   PHP-Scripte PHP-Tutorials PHP-Jobs und vieles mehr > Entwicklung > PHP Developer Forum
 

Login

 
eingeloggt bleiben
star Jetzt registrieren   star Passwort vergessen
 

 

 


PHP Developer Forum Hier habt ihr die Möglichkeit, eure Skriptprobleme mit anderen Anwendern zu diskutieren. Seid so fair und beantwortet auch Fragen von anderen Anwendern. Dieses Forum ist sowohl für ANFÄNGER als auch für PHP-Profis! Fragen zu Laravel, YII oder anderen PHP-Frameworks.

Antwort
 
LinkBack Themen-Optionen Thema bewerten
  #1 (permalink)  
Alt 28-07-2007, 20:10
kalleplom
 Registrierter Benutzer
Links : Onlinestatus : kalleplom ist offline
Registriert seit: Jun 2005
Beiträge: 141
kalleplom ist zur Zeit noch ein unbeschriebenes Blatt
Standard PEAR_Error Fehlermeldung

wahrscheinlich mal wieder ein Fehler, der nur in meinen Scripts vor kommt.

Ich wollte gestern mal die nette Firefox-Erweiterung FirePHP nutzen.
also
PEAR Package installiert und Script hineinkopiert.


PHP-Code:
require_once('FirePHP_Build/Init.inc.php');
 
// Set the FirePHP-AccessKey which will be compared to the cookie 
FirePHP::SetAccessKey('5364908fa4ff620472319bfb13447e74');
 
// Initialize the default FirePHP Wrapper
FirePHP::Init();

PEAR::setErrorHandling(PEAR_ERROR_CALLBACK'handle_pear_error');

  function 
handle_pear_error($ErrorObj) {
    if (
get_class($ErrorObj) == 'db_error')
      echo 
'DB-Fehler:<br />';
    else
      echo 
'Sonstiger PEAR-Fehler:<br />';
    die(
$ErrorObj->getMessage().'<br />'.$ErrorObj->getDebugInfo());
  } 

Zum Klassenladen benutze ich __autoload().

Wenn ich nun die Seite auf rufe, erhalte ich die Fehlermeldungen:

Code:
Warning: require_once(class/PEAR_Error.class.php) 
[function.require-once]: failed to open stream: 
No such file or directory in /var/.../functions.inc.php on line 20

Fatal error: require_once() [function.require]: Failed opening required 'class/PEAR_Error.class.php' 
(include_path='.:/usr/share/php:/usr/share/pear')
 in /var/.../functions.inc.php on line 20
Was kann ich denn da tun?
Wieso will er hier eine Klasse laden?
PEAR_Error ist kein PEAR-Paket, oder doch?
(apache2.2 / PHP5)

Vielen Dank für Eure Mühe!!


__________________
fragen macht spass, denken nicht
Mit Zitat antworten
  #2 (permalink)  
Alt 28-07-2007, 20:40
tontechniker
 PHP Senior
Links : Onlinestatus : tontechniker ist offline
Registriert seit: Jul 2005
Beiträge: 1.972
tontechniker ist zur Zeit noch ein unbeschriebenes Blatt
Standard

PHP Firefox-Erweiterung? Ansonsten wird die Klasse wohl gebraucht.
__________________
Die Regeln | rtfm | register_globals | strings | SQL-Injections | []
Mit Zitat antworten
  #3 (permalink)  
Alt 28-07-2007, 20:53
kalleplom
 Registrierter Benutzer
Links : Onlinestatus : kalleplom ist offline
Registriert seit: Jun 2005
Beiträge: 141
kalleplom ist zur Zeit noch ein unbeschriebenes Blatt
Standard

ja, FF-Erweiterung : http://www.firephp.org/

Aber woher bekomme ich denn diese Klasse?
Ich denke, es liegt an meinem Nicht-Verständnis für diese Art von PHP Entwicklung. Hmm..
Über PEAR installieren bringt jedenfalls nichts, da ein entsprechendes Paket nicht vorhanden ist.
__________________
fragen macht spass, denken nicht
Mit Zitat antworten
  #4 (permalink)  
Alt 28-07-2007, 21:03
Schnoop
 PHP Senior
Links : Onlinestatus : Schnoop ist offline
Registriert seit: Apr 2003
Beiträge: 1.049
Schnoop ist zur Zeit noch ein unbeschriebenes Blatt
Standard

Na ich würde mal auf pear.php.net gucken. Wo sonst?
Mit Zitat antworten
  #5 (permalink)  
Alt 28-07-2007, 21:39
kalleplom
 Registrierter Benutzer
Links : Onlinestatus : kalleplom ist offline
Registriert seit: Jun 2005
Beiträge: 141
kalleplom ist zur Zeit noch ein unbeschriebenes Blatt
Standard

ein
PHP-Code:
require_once('PEAR.php'); 
tut's auch. tja.


das PEAR_Error ist ein Teil der PEAR Klasse.
__________________
fragen macht spass, denken nicht
Mit Zitat antworten
Antwort

Lesezeichen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


PHP News

ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlicht
ebiz-trader 7.5.0 mit PHP7 Unterstützung veröffentlichtDie bekannte Marktplatzsoftware ebiz-trader ist in der Version 7.5.0 veröffentlicht worden.

28.05.2018 | Berni

Wissensbestand in Unternehmen
Wissensbestand in UnternehmenLebenslanges Lernen und Weiterbilden sichert Wissensbestand in Unternehmen

25.05.2018 | Berni


 

Aktuelle PHP Scripte

ADSMAN V3 - Werbe-Manager ansehen ADSMAN V3 - Werbe-Manager

ADSMAN V3 - mehr als nur ein Bannermanager! Banner, Textanzeigen und PagePeel Manager! Mit ADSMAN PRO haben Sie die Marketinglösung für eine effektive und effiziente Werbeschaltung mit messbaren Ergebnissen. Unterstützt werden Bannerformate in beliebi

25.10.2018 virtualsystem | Kategorie: PHP/ Bannerverwaltung
PHP News und Artikel Script V2

News schreiben, verwalten, veröffentlichen. Dies ist jetzt mit dem neuen PHP News & Artikel System von virtualsystem.de noch einfacher. Die integrierte Multi-User-Funktion und der WYSIWYG-Editor (MS-Office ähnliche Bedienung) ermöglichen...

25.10.2018 virtualsystem | Kategorie: PHP/ News
Top-Side Guestbook

Gästebuch auf Textbasis (kein MySQL nötig) mit Smilies, Ip Sperre (Zeit selbst einstellbar), Spamschutz, Captcha (Code-Eingabe), BB-Code, Hitcounter, Löschfunktion, Editierfunktion, Kommentarfunktion, Kürzung langer Wörter, Seiten- bzw. Blätterfunktion, V

22.10.2018 webmaster10 | Kategorie: PHP/ Gaestebuch
 Alle PHP Scripte anzeigen

Alle Zeitangaben in WEZ +2. Es ist jetzt 17:46 Uhr.