php-resource




Archiv verlassen und diese Seite im Standarddesign anzeigen :
value wird per GET nicht übergeben


 
SOB22
03-04-2005, 10:57 
 
hallo,

ich habe ein Suchformular, dass ich per GET abschicke


<table border="0" cellpadding="0" cellspacing="0"
class="table_haupt_rechts_unten">
<form name="form_review_suche_name" method="get" action="">

<tr>
<td class="aus_review_suche_name_oben">Name:</td>
<td class="aus_review_suche_feld_oben">
<input type="text" name="text_suche_name" class="textfeld_review_suche_name">
<input type="submit" name="senden_suche" class="button_review_suche" value="Suchen">
</td>
</tr>
</form>
</table>


wenn ich jetzt auf den Button "Suchen" klicke, wird alles korekt übergeben. Wenn ich aber ein Suchwort eingeben und einfach auf Enter drücken, wird der Value des Buttons nicht mehr übergeben "senden_suche=Suchen"!

Worann kann das liegen?

Gruß
Tim

 
em-!x
03-04-2005, 11:12 
 
Bei mir geht das wunderbar, habs eben ausprobiert.

Vielleicht liegts ja am doctype?

BTW: form ist in table nicht erlaubt!

stimmt der IE hat da Probleme...

 
SOB22
03-04-2005, 11:28 
 
ich habe den form tag mal aus der Tabelle rausgnommen. Lösst das Problem leider nicht.

Was mich sehr wundert ist, ich habe den selben Quellcode in einem anderen Skript verwendet und da funktionier es wunderbar?!

 
SOB22
03-04-2005, 11:31 
 
ich habe jetzt einfach ein hidden feld eingefügt

löst zumindest das Problem einmal vorläufig

<input type="hidden" name="senden_suche" value="Suchen">

 
ghostgambler
03-04-2005, 15:17 
 
Original geschrieben von SOB22
ich habe jetzt einfach ein hidden feld eingefügt

löst zumindest das Problem einmal vorläufig

<input type="hidden" name="senden_suche" value="Suchen">
Mach aus dem Button mal
<button type="submit" name="senden_suche" value="Suchen">Suchen</button>
und versuch es dann

-archiv-

Alle Zeitangaben in WEZ +2. Es ist jetzt 05:58 Uhr.